Npx cap sync ios never finishes

After I npx cap sync I get the following:

It doesn’t fail, it just never moves on. I have let this run to see if it just takes a lot of time but nothing ever happened.

Any suggestions? Thanks.

2 suggetions:

  • watch your network traffic and see if something is going on or is stuck
  • try to change internet connection, it happened to me often that the vpn blocked some npm update

Thanks. Nothing is stuck in the network traffic and I only have one internet connection. I am not using a vpn. xcode won’t open either. I am totally blocked. Yesterday it was working fine, then it just stopped working.

i mean, when you install something with npm you will see a process running and using your bandwidth,
if nothing is stuck i believe it’s just a matter of time.

ps: have you tried the following “magic” trick?

  • rm -rf node_modules
  • npm run clean
  • npm install

If Xcode doesn’t open, then that might be related.
Did you update something yesterday or today?

What do you get if you run xcode-select -p in a terminal?

I get this → /Applications/

I tried that but got the same behavior.

This issue was caused by icloud. There was problem with icloud continuously syncing files and never ending. Xcode thought the project I was working with was in the middle of a sync and would freeze up. My solution was to disable icloud and what do you know, everything worked just fine. Issue Resolved.