Npm dependency conflics

Ok so i was try to start working on the translations for my app and npm fails to properly install due to a conflict in the required versions of ionic vs ionic-angular.
here is the relevant section of the ionic package.json

    "@angular/common": "^4.3.6",
    "@angular/compiler": "^4.3.6",
    "@angular/compiler-cli": "^4.3.6",
    "@angular/core": "^4.3.6",
    "@angular/forms": "^4.3.6",
    "@angular/http": "^4.3.6",
    "@angular/platform-browser": "^4.3.6",
    "@angular/platform-browser-dynamic": "^4.3.6",
    "ionic-angular": "^3.6.1",

the problem is that ionic-angular is requiring versions 4.1.3 of the angular modules see below:

   { '@angular/common': '4.1.3',
     '@angular/compiler': '4.1.3',
     '@angular/compiler-cli': '4.1.3',
     '@angular/core': '4.1.3',
     '@angular/forms': '4.1.3',
     '@angular/http': '4.1.3',
     '@angular/platform-browser': '4.1.3',
     '@angular/platform-browser-dynamic': '4.1.3',
     rxjs: '5.4.0',
     'zone.js': '0.8.12' },

I’m not an npm expert but i would guess if ionic/my app is requiring 3.6.0 but ionic-angular is requiring exact versions of the angular modules we have a real problem. Anyone have a fix?

Given what you’ve said here, I think I know what is going on. You have two options:

  • carry on and accept that you are in uncharted waters. deliberately ignore these specific peer dependency warnings. incidentally, I am swimming along with you here and have yet to encounter any sharks
  • downgrade @ngx-translate/http-loader to 0.1.0 and the rest of your angular stuff to 4.1.3