NPM and angular error

I am new here. pardon my mistakes
I guess my project has a few outdated plugins.
however, I have tried both npm install @ionic-native/core --save and npm install @angular/common@4.0.1.

@ionic-native/core I get this error message: **npm WARN ionic-angular@3.3.0 requires a peer of @angular/platform-browser@4.1.2 but none was installed.**
@angular/common@4.0.1 produces: npm WARN @angular/common@4.0.1 requires a peer of @angular/core@4.0.1 but none was installed.

My package.json looks like this

  "name": "taxi",
  "version": "0.0.0",
  "author": "",
  "homepage": "",
  "private": true,
  "scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "lint": "ionic-app-scripts lint",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  "dependencies": {
    "@angular/common": "4.1.2",
    "@angular/compiler": "4.1.2",
    "@angular/compiler-cli": "4.1.2",
    "@angular/core": "4.1.2",
    "@angular/forms": "4.1.2",
    "@angular/http": "4.1.2",
    "@angular/platform-browser": "^4.1.2",
    "@angular/platform-browser-dynamic": "4.1.2",
    "@ionic-native/call-number": "^3.12.1",
    "@ionic-native/camera": "^3.12.1",
    "@ionic-native/core": "^4.1.0",
    "@ionic-native/push": "^3.12.1",
    "@ionic-native/social-sharing": "^3.12.1",
    "@ionic/storage": "2.0.1",
    "@types/googlemaps": "^3.26.13",
    "angularfire2": "^4.0.0-rc.1",
    "firebase": "^4.1.1",
    "google-libphonenumber": "^2.0.18",
    "ionic-angular": "3.3.0",
    "ionic-native": "^1.3.27",
    "ionicons": "3.0.0",
    "node-uuid": "^1.4.8",
    "rxjs": "5.1.1",
    "sw-toolbox": "3.6.0",
    "uuid": "^3.0.1",
    "zone.js": "0.8.11"
  "devDependencies": {
    "@ionic/app-scripts": "1.3.7",
    "ionic": "3.8.1",
    "typescript": "2.3.3"
  "cordovaPlugins": [],
  "cordovaPlatforms": [],
  "description": "i2Taxi: An Ionic project"

so am stack I guess am gonna need your help to fix this. I appreciate your effort very much.

Why are you installing 3.3 instead of 3.6?

Similar question: why are you fixated on angular 4.0.1?

Thing is nothing was working
But thanks cos I used the Prepare command and it fixed the errors one after the other.
Thanks for prompting me though