UNMET PEER DEPENDENCY @ionic-native/core@4.6.0


#1

I’m getting below error while installing ionic-native code, can someone help?

npm install @ionic-native/core --save
ionic-hello-world@ /Users/sajith/Desktop/Dev/ionic3-angular4-sample-app-master
└── UNMET PEER DEPENDENCY @ionic-native/core@4.6.0

npm WARN @ionic-native/splash-screen@3.4.2 requires a peer of @ionic-native/core@^3.1.0 but none was installed.
npm WARN @ionic-native/status-bar@3.4.2 requires a peer of @ionic-native/core@^3.1.0 but none was installed.
npm ERR! code 1

package.json:

{
“name”: “ionic-hello-world”,
“author”: “Ionic Framework”,
“homepage”: “http://ionicframework.com/”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
},
“dependencies”: {
@angular/common”: “5.2.9”,
@angular/compiler”: “5.2.9”,
@angular/compiler-cli”: “5.2.9”,
@angular/core”: “5.2.9”,
@angular/forms”: “5.2.9”,
@angular/http”: “5.2.9”,
@angular/platform-browser”: “5.2.9”,
@angular/platform-browser-dynamic”: “5.2.9”,
@ionic-native/contacts”: “^4.6.0”,
@ionic-native/core”: “^4.6.0”,
@ionic-native/splash-screen”: “4.6.0”,
@ionic-native/status-bar”: “4.6.0”,
@ionic/storage”: “2.1.3”,
“cordova-ios”: “~4.5.4”,
“cordova-plugin-contacts”: “3.0.1”,
“cordova-plugin-device”: “2.0.1”,
“cordova-plugin-ionic-keyboard”: “2.0.5”,
“cordova-plugin-ionic-webview”: “1.1.16”,
“cordova-plugin-splashscreen”: “5.0.2”,
“cordova-plugin-whitelist”: “1.3.3”,
“ionic-angular”: “3.9.2”,
“ionic-native”: “^2.9.0”,
“ionicons”: “3.0.0”,
“rxjs”: “5.5.8”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.23”
},
“devDependencies”: {
@ionic/app-scripts”: “3.1.8”,
“typescript”: “~2.8.1”
},
“cordovaPlugins”: [
“cordova-plugin-whitelist”,
“cordova-plugin-console”,
“cordova-plugin-statusbar”,
“cordova-plugin-device”,
“cordova-plugin-splashscreen”,
“ionic-plugin-keyboard”
],
“cordovaPlatforms”: [
“ios”,
{
“platform”: “ios”,
“version”: “”,
“locator”: “ios”
}
],
“description”: “ionic3-angular4: An Ionic project”,
“cordova”: {
“plugins”: {
“cordova-plugin-whitelist”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-ionic-webview”: {},
“cordova-plugin-ionic-keyboard”: {},
“cordova-plugin-contacts”: {
“CONTACTS_USAGE_DESCRIPTION”: “please allow”
}
},
“platforms”: [
“ios”
]
}
}


#2

Run npm update and see what happens. Your installed version of the plugins does not match what’s in package.json.


#3

Update updating the npm, seems like something changed and i’m getting below error message while installing core

├── @ionic-native/core@4.6.0
└── UNMET PEER DEPENDENCY typescript@2.8.1

npm WARN @angular/compiler-cli@5.2.9 requires a peer of typescript@>=2.4.2 <2.7 but none was installed.
npm WARN tsickle@0.27.2 requires a peer of typescript@>=2.4.2 <2.8 but none was installed.


#4

What’s your ionic info output?


#5

Same here.

It has always happend to me everytime I try to update ionic-native/core, regardless the version.