Not correctly run in android 5 and 4.4 with ionic 4.2.0

#1

I updated ionic of 4.0.0rc2 to 4.2.0 and update all plugins then get output but not correctly run android 4.4 and 5.
console log in android 5:

 deviceready not firing

ionic info :

      Ionic:

       ionic (Ionic CLI)             : 4.12.0 (/usr/local/lib/node_modules/ionic)
       Ionic Framework               : @ionic/angular 4.2.0
       @angular-devkit/build-angular : 0.13.8
       @angular-devkit/schematics    : 7.3.8
       @angular/cli                  : 7.3.8
       @ionic/angular-toolkit        : 1.5.0

      Cordova:

       cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
       Cordova Platforms     : android 7.1.4
       Cordova Plugins       : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 4.0.1, (and 15 other plugins)

package.json :

"dependencies": {
"@angular/common": "~7.2.12",
"@angular/core": "~7.2.12",
"@angular/forms": "~7.2.12",
"@angular/http": "~7.2.12",
"@angular/platform-browser": "~7.2.12",
"@angular/platform-browser-dynamic": "~7.2.12",
"@angular/router": "~7.2.12",
"@ionic-native/android-permissions": "^5.4.0",
"@ionic-native/barcode-scanner": "^5.4.0",
"@ionic-native/core": "^5.4.0",
"@ionic-native/deeplinks": "^5.4.0",
"@ionic-native/device": "5.4.0",
"@ionic-native/diagnostic": "5.4.0",
"@ionic-native/file": "5.4.0",
"@ionic-native/file-opener": "5.4.0",
"@ionic-native/file-transfer": "5.4.0",
"@ionic-native/location-accuracy": "5.4.0",
"@ionic-native/network": "5.4.0",
"@ionic-native/social-sharing": "5.4.0",
"@ionic-native/splash-screen": "5.4.0",
"@ionic-native/status-bar": "5.4.0",
"@ionic/angular": "4.2.0",
"@ionic/storage": "^2.2.0",
"@ngx-translate/core": "^11.0.1",
"@ngx-translate/http-loader": "^4.0.0",
"@types/materialize-css": "^1.0.6",
"com.lampa.startapp": "^6.1.6",
"cordova": "^8.1.2",
"cordova-android": "7.1.4",
"cordova-plugin-android-permissions": "^1.0.0",
"cordova-plugin-device": "^2.0.2",
"cordova-plugin-file": "^6.0.1",
"cordova-plugin-file-opener2": "^2.2.0",
"cordova-plugin-file-transfer": "^1.7.1",
"cordova-plugin-inappbrowser": "^3.0.0",
"cordova-plugin-ionic-keyboard": "^2.1.3",
"cordova-plugin-ionic-webview": "^4.0.1",
"cordova-plugin-mauron85-background-geolocation": "^3.0.1",
"cordova-plugin-network-information": "^2.0.1",
"cordova-plugin-request-location-accuracy": "^2.2.3",
"cordova-plugin-sms-receive": "^1.0.2",
"cordova-plugin-splashscreen": "^5.0.2",
"cordova-plugin-statusbar": "^2.4.2",
"cordova-plugin-whitelist": "^1.3.3",
"cordova-sqlite-storage": "^3.2.0",
"cordova.plugins.diagnostic": "^4.0.12",
"core-js": "^3.0.1",
"ionic-plugin-deeplinks": "^1.0.19",
"ionicons": "4.5.5",
"lodash": "4.17.11",
"materialize-css": "^1.0.0",
"moment": "2.24.0",
"moment-jalaali": "0.8.3",
"parse-push-plugin": "git+https://github.com/taivo/parse-push-plugin.git",
"phonegap-plugin-barcodescanner": "^8.0.1",
"rxjs": "6.4.0",
"rxjs-compat": "^6.4.0",
"ws": "^6.2.1",
"zone.js": "^0.9.0"
},

"devDependencies": {
"@angular-devkit/architect": "~0.13.8",
"@angular-devkit/build-angular": "~0.13.8",
"@angular-devkit/core": "~7.3.8",
"@angular-devkit/schematics": "~7.3.8",
"@angular/cli": "~7.3.8",
"@angular/compiler": "~7.2.12",
"@angular/compiler-cli": "~7.2.12",
"@angular/language-service": "~7.2.12",
"@ionic/angular-toolkit": "^1.5.0",
"@ionic/lab": "1.0.24",
"@types/jasmine": "~3.3.12",
"@types/jasminewd2": "~2.0.6",
"@types/node": "~11.13.2",
"codelyzer": "~5.0.0",
"jasmine-core": "~3.4.0",
"jasmine-spec-reporter": "~4.2.1",
"karma": "~4.0.1",
"karma-chrome-launcher": "~2.2.0",
"karma-coverage-istanbul-reporter": "~2.0.5",
"karma-jasmine": "~2.0.1",
"karma-jasmine-html-reporter": "^1.4.0",
"protractor": "~5.4.2",
"ts-node": "~8.0.3",
"tslint": "~5.15.0",
"typescript": "~3.2.4"
}
1 Like