New crosswalk 1.5.0 and android 5.1.1 are not working


#1

Hey there,

Just created a new ionic start (tabs for example), add the new android 5.1.1 from cordova and then do
cordova plugin add cordova-plugin-crosswalk-webview

The application is not working anymore (the [appname] has stopped)

Any idea for resolving that ?
Do you think it is with the new android version ? or the 1.5.0 crosswalk ?

Thanks !


#2

Any ideas ? Without crosswalk the application is so slow


#3

Still the same with the crosswalk 1.6.0. Nobody has this issue I guess ?


#4

Hmm, not able to replicate this unfortunately.
Have you tried with a blank project?


#5

Hi,

Yes I also tried with a cordova simple project. It is also happening, thus it is not ionic obviously. I tried reinstalling cordova (v 6.0.0), but it is still the same. I really do not know then…


#6

@mhartington I contacted crosswalk and they are knowing this issue.

One issue is here : https://crosswalk-project.org/jira/browse/XWALK-6141

And one of the developer told me : “The stopped working issue was caused by upstream Chromium, please use Crosswalk 18 to test. We will promote Crosswalk 18 from beta to stable soon.”

Hope these helps.
Thibaut


#7

Oh interesting…

Awesome, thanks for looping me in :grin:


#8

@mike, Thanks to @harishgadiya92, we found this : On genymotion device, the splashcreen plugin AND/OR crosswalk plugin are creating the issue.

But on a real device, only the splashscreen plugin is doing it. So, at this moment, just do not use splashscreen plugin on android.

https://issues.apache.org/jira/browse/CB-10562?jql=project%20%3D%20CB%20AND%20status%20in%20(Open%2C%20"In%20Progress"%2C%20Reopened)%20AND%20resolution%20%3D%20Unresolved%20AND%20component%20%3D%20"Plugin%20Splashscreen"%20ORDER%20BY%20priority%20DESC%2C%20summary%20ASC%2C%20updatedDate%20DESC

Thanks again harishgadiya