My ionic pro cloud build fails because of 'cordova prepare' error?


#1

For some reason my builds are failing when I run ionic build or when I push to the build to the ionic cloud. Here is the output in the cloud:

Running with gitlab-ci-multi-runner 9.1.0 (0118d89)
  on Prod Snapshot Builds 1 (c9648220)
Using Shell executor...
Running on ip-10-2-78-88...
Cloning repository...
Cloning into '/home/gitlab-runner/builds/c9648220/0/project-1'...
Checking out 3b0a0d87 as master...
Skipping Git submodules setup
$ fetch-updates
Checking for build process updates...
$ build-app
Fetching build dependencies...
Running after script...
$ clean-up
Cleaning up files...
Successful clean up
ERROR: Job failed: exit status 1

Here’s the output when I run ionic build --verbose (it seems to snag on cordova prepare):

C:\Users\User\Code\YOUAREACREATOR\HummingBiirdBeta>ionic build --verbose
[DEBUG] CLI flags: { interactive: true, confirm: false }
[DEBUG] { cwd: 'C:\\Users\\User\\Code\\YOUAREACREATOR\\HummingBiirdBeta', local: true, binPath:
        'C:\\Users\\User\\AppData\\Roaming\\npm\\node_modules\\ionic\\bin\\ionic', libPath:
        'C:\\Users\\User\\Code\\YOUAREACREATOR\\HummingBiirdBeta\\node_modules\\ionic\\dist\\index.js' }
[DEBUG] Daemon found (pid: 19140)
Running app-scripts build:
[17:34:13]  build dev started ...
[17:34:13]  clean started ...
[17:34:13]  clean finished in 20 ms
[17:34:13]  copy started ...
[17:34:13]  transpile started ...
[17:34:16]  transpile finished in 3.76 s
[17:34:16]  preprocess started ...
[17:34:16]  deeplinks started ...
[17:34:17]  deeplinks finished in 265 ms
[17:34:17]  preprocess finished in 267 ms
[17:34:17]  webpack started ...
[17:34:21]  copy finished in 7.97 s
[17:34:28]  webpack finished in 10.82 s
[17:34:28]  sass started ...
[17:34:29]  sass finished in 1.31 s
[17:34:29]  postprocess started ...
[17:34:29]  postprocess finished in 11 ms
[17:34:29]  lint started ...
[17:34:29]  build dev finished in 16.23 s
> ionic cordova prepare --no-build
> cordova prepare
No valid rules have been specified
[17:34:32]  lint finished in 2.80 s
Error: doc.find is not a function

[ERROR] An error occurred while running cordova prepare (exit code 1).

This wasn’t an issue before I upgraded the cli. Here is my system info.

cli packages: (C:\Users\User\Code\YOUAREACREATOR\HummingBiirdBeta\node_modules)

@ionic/cli-utils  : 1.18.0
ionic (Ionic CLI) : 3.18.0

global packages:

cordova (Cordova CLI) : 7.1.0

local packages:

@ionic/app-scripts : 2.1.4
Cordova Platforms  : browser 5.0.1 ios 4.5.3
Ionic Framework    : ionic-angular 3.6.1

System:

Node : v6.10.2
npm  : 3.10.10
OS   : Windows 10

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

#2

Huh, since when does this run cordova prepare inside?


#3

Hey.
i am seeing the same thing. did you manged to solve it?