'My App' may slow down your iPhone. The developer of this app bla bla~


#1

When running my project on iOS simulator, that warning pops up only once at launching.
I searched for a while and found the warning is actually saying that my app is NOT built with 64bit architecture.
If it’s the reason, what should I do to remove that warning?
Build app for 64bit? How?
Frankly, I have no idea which architecture my app is currently built with.


#2

Hi Vincent, did you get anywhere with this?


#3

No, nothing. That only happens for the first time so I’m not sure this problem still continues. My app is not published yet and I have tested with only three phones. (All three showed that msg though)


#4

See this thread: Performance alert when deploying to iOS 10.1

It may resolve your issue.

You may want to uninstall and reinstall cordova as well


#5

Instaliing WKWebview solved this issue. It’s much faster than UIWebview.


#6

I’m running into the same problem with an iOS 10 device.

Tried installing the WKWebview plugin but get the same error after building and running on the device.

Has anyone figured out a way to avoid this error in ionic 2 apps???


#7

Try ionic build ios --prod
This will optimize your build and perhaps the message will disappear?
My app is based on RC.5


#8

Unfortunately I can’t… as I am using ionic package build ios (running Windows locally).


#9

So as far as anyone knows, does Ionic Package have a way to avoid this?

Seems like it’s going to be a problem on new devices (making the whole benefit of Ionic Package go away). Given the work put into to provide that feature as part of Ionic 2 it seems like there would be a solution?


#10

I checked and realized you can use the --prod setting with ionic package build ios… unfortunately, same result.

Anyone have ideas for how to avoid this warning with ionic 2 projects on iOS 10+ devices?


#11

I’m having this issue as well. I’m using Ionic to package and deploy the app for testing with the .ipa right now. How do we get this message to stop appearing?


#12

I am having the same issue, any idea ?


#13

Any news about this problem ?


#14

I was having the same issue so I opened a ticket with Ionic primary support. They just recently upgraded Ionic Package in the 15 May 2017 timeframe. The 32 bit issue, which was causing the “… May Slow Down Your iPhone …” message should be resolved by the recent Xcode upgrade in Ionic Package.