Many warnings after update @ionic-native/core


#1

After i run ionic doctor check the program show me an issue:
The version of @ionic-native/core is too old.

After I upgraded this with a specific command i have these warnings:

npm WARN @ionic-native/app-availability@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/app-rate@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/background-mode@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/call-number@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/date-picker@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/diagnostic@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/geolocation@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/in-app-browser@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/keyboard@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/launch-navigator@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/media@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/native-audio@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/network@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/onesignal@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/social-sharing@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/splash-screen@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/status-bar@3.12.1 requires a peer of @ionic-native/core@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN angularfire2@4.0.0-rc.1 requires a peer of @angular/common@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angularfire2@4.0.0-rc.1 requires a peer of @angular/compiler@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angularfire2@4.0.0-rc.1 requires a peer of @angular/core@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angularfire2@4.0.0-rc.1 requires a peer of @angular/platform-browser@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angularfire2@4.0.0-rc.1 requires a peer of @angular/platform-browser-dynamic@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angularfire2@4.0.0-rc.1 requires a peer of firebase@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN worker-loader@0.8.0 requires a peer of webpack@>=0.9 <2 || ^2.1.0-beta || ^2.2.0 but none is installed. You must install peer dependencies yourself.

Now I can resolve this?

Thank You


#2

Hello,

our package.json holds what for version are installed.

If your app works as you wish, then you can ignore the warnings, but get problems later with outdated versions.

If you want update your versions you can change in package.json the versions. For editors, like vs code, are extensions available, that helps with dealing them.

Because there are many warnings I would always recommend to backup package.json and update only a few versions. After sucess full testing, the next bunch of versions.

Best regards, anna-liebt


#3

do you have the name of extension of VSCODE?


#4

If you get weird compilation errors, especially when building --prod, then you need to take these warnings seriously. Until then, get to it when you can. Though you’re using an old version of AF2 and might want to update that now. That seems like a more serious issue because of bug fixes.


#5

Hello,
maybe npm, npm dependency, npm intellisense…

And as Aaron stated, test careful, because otherwise it gets hard to find the failure.

Beest regards, anna-liebt.