Concerned about peerinvalid errors


#1

I’ve been seeing these errors a lot lately (after updating to 3.9.2). Should I be concerned about them or ignore?

npm ERR! peerinvalid The package @ionic-native/core@3.12.1 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer @ionic-native/calendar@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/camera@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/clipboard@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/contacts@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/deeplinks@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/file@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/file-transfer@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/in-app-browser@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/in-app-purchase@4.4.0 wants @ionic-native/core@^4.2.0

npm ERR! peerinvalid Peer @ionic-native/keyboard@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/onesignal@4.4.0 wants @ionic-native/core@^4.2.0
npm ERR! peerinvalid Peer @ionic-native/splash-screen@3.12.1 wants @ionic-native/core@^3.6.0
npm ERR! peerinvalid Peer @ionic-native/status-bar@3.12.1 wants @ionic-native/core@^3.6.0

#2

You should update all of your ionic native package versions to be the same.


#3

ok, thanks. I kinda wish this was mentioned for the upgrade docs.


#4

It’s one of those cases where it’s not part of the framework itself, so they don’t explicitly state keeping your other dependencies up-to-date.