Latest Cordova still too old?

5.3.3 is DEFINETLY the latest version of cordova. Am I missing something?

(bvenv)justin@Winterfel ~/workspace/ionictest $ ionic start MyIonicV2App --v2
The directory /home/justin/workspace/ionictest/MyIonicV2App already exists.
Would you like to overwrite the directory with this new project?
(yes/no): yes
Starting an Ionic v2 application
Downloading: https://github.com/driftyco/ionic2-starter-tabs/archive/master.zip
[=============================] 100% 0.0s
Installing Node Modules
Updated the hooks directory to have execute permissions
Adding native plugins

Unable to add plugins. Perhaps your version of Cordova is too old. Try updating (npm install -g cordova), removing this project folder, and trying again. (CLI v2.0.0-alpha.9)

Your system information:

Cordova CLI: 5.3.3
Gulp version: CLI version 0.1.5
Gulp local: Local version 3.9.0
Ionic Version: 2.0.0-alpha.30
Ionic CLI Version: 2.0.0-alpha.9
Ionic App Lib Version: 0.5.0-alpha.9
OS: Distributor ID: LinuxMint Description: Linux Mint 17.1 Rebecca
Node Version: v4.2.1

Could be other problems. Why not try new projects in Hong Kong instead of using starter on github?

Running into the same issue here with a similar configuration.

nicoabie@minty ~/Development $ sudo ionic start ionic2test --v2
Starting an Ionic v2 application
Downloading: https://github.com/driftyco/ionic2-starter-tabs/archive/master.zip
[=============================] 100% 0.0s
Installing Node Modules
Updated the hooks directory to have execute permissions
Adding native plugins

Unable to add plugins. Perhaps your version of Cordova is too old. Try updating (npm install -g cordova), removing this project folder, and trying again. (CLI v2.0.0-alpha.9)

Your system information:

Cordova CLI: 5.3.3
Gulp version: CLI version 3.8.11
Gulp local: Local version 3.9.0
Ionic Version: 2.0.0-alpha.30
Ionic CLI Version: 2.0.0-alpha.9
Ionic App Lib Version: 0.5.0-alpha.9
OS: Distributor ID: LinuxMint Description: Linux Mint 17 Qiana
Node Version: v4.2.1