Keyboard does not open on iOS Simulator

If you run your app in simulator, and the iOS keyboard does not display on input fields, do not be alarmed (like I was!).

You’ve probably just turned the on-screen keyboard off by accident. There is a menu option Hardware > Keyboard > Connect Hardware Keyboard which does this. It is to simulate iOS when an external keyboard is connected.

Here’s what the app looks like:

That’s the default ‘sidebar’ template app, with the keyboard accessory bar turned on just to show that the app is in input mode.

This tripped me up for a bit, so just sharing here in case someone else does the same.

4 Likes

I’ve had this happen as well. ⌘+K will toggle the keyboard.

6 Likes

This is something that changed in the new ios-simulator.

You can use control-k like @maxg7 suggested,
or you can change this by going Hardware> Connect Hardware Keyboard.
Uncheck this setting.

4 Likes

I had the same issue and panicked like you. I fixed it with cmd + K. Thank you for sharing. It works with Xcode 10 simulator. If you run into a similar issue, just try cmd + K.