Keyboard-attach broken in beta.10


#1

Hi, I have been using keyboard-attach and I just upgraded to beta.10 and now it doesn’t work - or better yet, it’s behaving weirdly.

I am correctly using it though - only with ion-footer-bar and I call disableScroll(true) whenever that directive is used. Before, the input field used to jump up with the keyboard but now you can see the cursor to start typing (and if you do type, the value goes into the input bar) but the actual footer-bar is still behind the keyboard at the bottom.

Anyone else seeing this as well or should I upload a codepen.

Thanks in advance.


#2

Hmm, I’m not seeing this in my test. Any way you can throw your code in a codepen then I can try in on a device?


#3

I downgraded to beta.9 and it worked an then upgraded back… seems to work now. Sorry for wasting time but thanks for helping out!

Edit: And it seems to be back to not working… Will update with code pen in a little bit…


#4

I was just about to try the keyboard-attach and it doesn’t really work with me too…


#5

Anyway you can get a screen cast of this? Just to know in more detail what the issue is exactly


#6

Hi mhartington,
I just try this on my page :

<ion-footer-bar align-title="right" keyboard-attach class="bar-light item-button-right"> 
<button class="button button-clear button-positive">Valider</button>
</ion-footer-bar>

Result:

[Screen][1]
[Screen][2]

NB: I use ios8 betâ but I don’t kown…


#7

Mine reacts differently. The footer bar stays behind the keyboard. You can see the cursor in the second picture but not the footer bar. I am using iOS 7 with no updates… Here is the code for mine:

<ion-footer-bar keyboard-attach>
  <form class="input-holder">
    <div class="textarea-holder">
      <textarea placeholder="Message"></textarea>
    </div>
    <button class="button button-clear" type="submit">Send</button>
  </form>
</ion-footer-bar>


#8

Mine…


#9

Hey @migueltarga, you shouldn’t need keyboard attach since Android resizes the view by default when you’re not in fullscreen mode: http://ionicframework.com/docs/api/directive/keyboardAttach/. Unless you have specified a value for android:windowSoftInputMode that isn’t the default, in which case you can try adjusting that.

@prateeksach would be able to upload a codepen replicating this? It sounds like it might have broken in beta 10.


#10

Hey, sorry this took so long. I tried a codepen and then on my device and it worked… then i went back to my code, broke it down to the simplest and went back up - seems to have been an error on my side. my apologies for wasting the time.