iTunes Store Operation Failed - Missing Marketing Icon


#1

When I tried to upload the build for testFlight I got this error: “WARNING ITMS-90704: “Missing Marketing Icon. iOS Apps must include a 1024x1024px Marketing Icon in PNG format. Apps that do not include the Marketing Icon cannot be submitted for App Review or Beta App Review.””. I had done an upload successfully before I updating XCode but after updating this stuck on this. Already tried re generating resources and building again, it shows extra 2 icons created with 1024X1024 but the upload failed.


#2

I’m having the same issue. Regenerating resources didn’t help. I could (temporarily) fix the issue by manually adding the required icon in Xcode (AppIcon).


#3

This has been addressed in cordova-ios@4.5.1 - you can now specify it in config.xml. I haven’t updated yet, so I just dragged the 1024x1024 non-alpha png into the project for now


#4

I have tried going the ionic resources route with no luck and i have tried drag/drop to xcode; also with no luck. Can someone that has gotten either the right way (using ionic) or the less right way (xcode) add a little more detail here please. Like what is the file name, what do you add to config files, etc.

I have updated ionic/cordova/etc and this in xcode. Still nothing works.

thanks.


#5

Same here, have you found the solution?


#6

I did finally get this working, these were my steps although i am sure some of them may not be required (ionic resources command should do most of this but i don’t think it is working):

  1. converted icon.png to icon.jpg - this just ensures it isn’t transparent
  2. added this line to config.xml
  • in all the posts i have read this path is different; so possibly this is just a function of our specific setup??
  1. updated cordova cli (likely not required)
  2. removed cordova-plugin-console
  3. after ionic ios build, manually moved icon.jpg to resources/ios folder
  4. inside xcode drag/drop same icon to holder for Project->Resources->images.xcassets->AppIcon->App Store iOS 1024pt

then archive and upload as usual.


#7

I had to manually put icon into XCode as well. Any idea when this will be fixed in Ionic (assuming that is where the issue is)?


#8

The issue is/was with Cordova.

Post your ionic info output so we can see what you are using there.


#9

The solution for me was a DNS problem I ran the same command connected to a different network and worked just fine!
:grinning: