Issues with crosswalk on android emulators, (almost) blank screen, but elements are still there when seen through developers tools


#1

I have searched, this does not seem to be the usual “blank screen” issues all over the internet.

If I have the crosswalk plugin installed the app works fine on my phone (Android 4.1.2) but not on emulators (tried API 16, 17, 22 and 23 on Genymotion and regular emulator), the screen only shows the header/toolbar/navbar in its background color, no text is seen anywhere, if I open developers console the HTML is all there (and no errors are displayed in console), hell if I click somewhere the events are running, the app is “working” in a sense, I just can’t see it working. If I uninstall crosswalk then the app will work fine on the emulators, but won’t work on my phone, I assume because of the older version.

This seems to happen with every single app. If I just run ionic new with the tutorial template and install crosswalk, the same thing happens.

Screenshots:

Blank everything, except the header: If I inspect, I can see in the HTML everything is there, I added console logs to several of my handlers, and everything works, things are happening.

I can slide the menu, but it’s like the content hides everything.

Any help would be appreciated.

Your system information:

Cordova CLI: You have been opted out of telemetry. To change this, run: cordova telemetry on.
6.3.1

Gulp version:  CLI version 3.9.1
Gulp local:   Local version 3.9.1
Ionic Framework Version: 2.0.0-beta.11
Ionic CLI Version: 2.0.0-beta.37
Ionic App Lib Version: 2.0.0-beta.20
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Mac OS X El Capitan
Node Version: v5.12.0
Xcode version: Xcode 7.3 Build version 7D111g

#2

I have the same issue, did you manage to get it solved?

Thanks.


#3

I did actually, turns out I had an outdated JRE/JDK and Android build tools.


#4

Hello @GGalizzi
I have the same issue, i’ve deleted all outdated Android build tools
and update JDK
but it’s not works :frowning: do you have any suggestion ? pleas
thanks.


#5

Same issue in my apps. I’ve updated cordova-plugin-crosswalk-webview to version 2.2 and problem remains. I don’t have any Android device to check it so I belived the emulator that it doesn’t work. I’ve debugged the app and everything is there - the music is playing, the ad is showing, I can event click on the emulator and can see that ion-nav received another page. EVERYTHING works except displaying the app (only the header is visible).

The only way to make it work on the emulator is to put:

<preference name="xwalkVersion" value="18+" /> in the config.xml and downgrade cordova-plugin-crosswalk-webview to 1.7.

Did anyone managed to resolve the issue? Or another question - do you use crosswalk and don’t have any problems on the emulator?


#6

Same here.

Work on device but on emulator showing white screen. Examinig DOM - everything is OK. Removing crosswalk - work on emulator but not on device (I am testing on Android 4.2.1 device - so I need crosswalk).
Changing crosswalk version does not work for me. I am using Visual Studio for debugging and changing version in config.xml invoke errors in compilation.
Trying also all steps mentioned here with no results.

Any help will be appreciated.


#7

Same here.

Works on device (ARM build) but fails on Genymotion. I tried on various nexus devices in genymotion with various crosswalk version (beta and stable)

I noticed that the application fails with cordova-android 6+, crosswalk.
I was using cordova-android 5 with crosswalk 15 which was working fine and is still working fine with older version but found issue with latest version.

Anybody found any solution??

Additionally;

I tried crosswalk with android platform 5.2.2. Below are the plugins and versions:
cordova-plugin-console 1.0.2 "Console"
cordova-plugin-crosswalk-webview 1.8.0 "Crosswalk WebView Engine"
cordova-plugin-device 1.1.2 "Device"
cordova-plugin-fileopener 1.0.4 "FileOpener"
cordova-plugin-inappbrowser 1.4.0 "InAppBrowser"
cordova-plugin-splashscreen 3.2.2 "Splashscreen"
cordova-plugin-statusbar 2.1.3 "StatusBar"
cordova-plugin-transport-security 0.1.2 "App Transport Security"
cordova-plugin-whitelist 1.2.2 "Whitelist"
cordova-plugin-x-toast 2.5.2 "Toast"
hu.dpal.phonegap.plugins.PinDialog 0.1.2 "PinDialog"
hu.dpal.phonegap.plugins.UniqueDeviceID 1.2.0 "UniqueDeviceID"
ionic-plugin-keyboard 2.2.1 "Keyboard"
phonegap-plugin-push 1.6.3 “PushPlugin”

Now, When I use “xwalkVersion=18+” the build is working fine on genymotion Nexus 6 - 5.1.0 API 22
When I use xwalkVersion=19+ the build is showing white page.

However, I noticed that the controls are still there but not visible. I did some clicks and nevigated application, after 3-4 navigations UI suddenly visible.

Any clues??


#9

any updates on this ? I have the same issues :frowning:


#10

you have to use a real device not an emulator. I don’t know why it works on a real device an not on an emulator. Maybe some APIs are missing on the emulator


#11

I believe it is related to graphics acceleration - I’ve found turning graphics to software GLES instead of hardware allows crosswalk to run on the android emulators - albeit a bit slower.