Crosswalk doesn't render anything


#1

Hi!
I’ve added Crosswalk to my Ionic 2 Project via the “ionic plugin add cordova-plugin-crosswalk-webview” CLI Command because the Android Simulator didn’t play videofiles (only played audio). After trying with several video files and formats and getting a little deeper into the ionic framework I thought it might be a good idea to add crosswalk anyway. Now… The Problem is that since adding Crosswalk everything is messed up and the Emulator shows a pure blank page with the notion of an ion-header element:

In fact every element is there with it’s functionality basically not showing any fonts, colors, borders etc. The Chrome Dev Tools show that he fetched everything.
Guessing where the buttons should be I even got through the Login Screen and tada ironically the video does play now in the emulator. Just everything else doesn’t render… Tried cordova clean, cordova build, ionic build etc. Tried it with some other Project, different Android Emulator Setups. But no luck.

This is what he should render (and did before crosswalk):

Can somebody please tell me I’m completely retarded and that there’s a simple solution to this?

I’m using:

Cordova CLI: 6.3.1
Ionic CLI Version: 2.0.0
Ionic App Lib Version: 2.0.0-beta.20
ios-deploy version: 1.9.0
ios-sim version: Not installed
OS: Mac OS X El Capitan (actually macOS Sierra if that matters)
Node Version: v4.5.0
Xcode version: Xcode 8.0 Build version 8A218a


#2

I have same issue and not found a solution yet


#3

I had the same thing its usually when running on devices lower then android 4.4.
4.4+ worked fine for me.
Sunk some time into it and went on the ionic slack looking for an answer but it seems like this might be an issue for older devices.
(kind of the point of XWalk)


#4

I use this workaround: removed this plugin to run/debug in emulators, after this, i added this plugin again to build for real devices


#5

Is Crosswalk still needed?

Do video files not play without?


#6

Still required to render complex views depending the version of device