IOS Production Build


I’ve been trying to export a production build for IOS and have been having issues. Can someone please assist.

Wow, that very less info :smiley: What are your issues?

1 Like

Sorry for that, it’s my first time building an ionic app build via a Mac, and it’s showing me flames. I have followed steps on the ionic page to do setup and build but for some reason, I am having issues.

When I run ionic Cordova build iOS --prod --release

This is the error below:

Wrote out iOS Bundle Version "1.3.8" to /Users/admin/Development/App/platforms/iOS/App/App-Info.plist
iOS Product Name has not changed (still "App")
Updating icons at platforms/iOS/App/Images.xcassets/AppIcon.appiconset/
Updating launch storyboard images at platforms/iOS/App/Images.xcassets/LaunchStoryboard.imageset/
Updating Storyboard image set contents.json
Updating Background Color color set Contents.json
This app does not have additional resource files defined
Prepared iOS project successfully
Executing script found in plugin cordova-plugin-add-swift-support for hook "after_prepare": plugins/cordova-plugin-add-swift-support/src/add-swift-support.js
No scripts found for hook "before_compile".
Running command: xcodebuild -version
Command finished with error code 0: xcodebuild -version
Running command: ioreg -p IOUSB -l
Command finished with error code 0: ioreg -p,IOUSB,-l
Running command: xcrun simctl list --json
Command finished with error code 0: xcrun simctl,list,--json
Running command: xcrun simctl list --json
Command finished with error code 0: xcrun simctl,list,--json
Cannot read property 'name' of undefined
TypeError: Cannot read property 'name' of undefined
    at /Users/admin/Development/App/platforms/ios/cordova/lib/build.js:145:60
    at _fulfilled (/Users/admin/Development/App/node_modules/q/q.js:854:54)
    at /Users/admin/Development/App/node_modules/q/q.js:883:30
    at Promise.promise.promiseDispatch (/Users/admin/Development/App/node_modules/q/q.js:816:13)
    at /Users/admin/Development/App/node_modules/q/q.js:624:44
    at runSingle (/Users/admin/Development/App/node_modules/q/q.js:137:13)
    at flush (/Users/admin/Development/App/node_modules/q/q.js:125:13)
    at processTicksAndRejections (internal/process/task_queues.js:75:11)
[ERROR] An error occurred while running subprocess cordova.
        cordova build ios --release --verbose exited with exit code 1.
        Re-running this command with the --verbose flag may provide more information.
  ionic:utils-process onBeforeExit handler: 'process.exit' received +0ms
  ionic:utils-process onBeforeExit handler: running 2 functions +0ms
  ionic:utils-process processExit: exiting (exit code: 1) +42ms

I have tried to do a build on a new project and samething happened. I did a build for android and its working fine on a windows machine I was doing dev on for the project.

Here is my ionic info data


   Ionic CLI                     : 6.12.4 (/usr/local/lib/node_modules/@ionic/cli)
   Ionic Framework               : @ionic/angular 5.5.3
   @angular-devkit/build-angular : 0.1100.7
   @angular-devkit/schematics    : 11.0.7
   @angular/cli                  : 11.0.7
   @ionic/angular-toolkit        : 3.0.0


   Cordova CLI       : 10.0.0
   Cordova Platforms : ios 6.1.1
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 5.0.0, (and 15 other plugins)


   cordova-res : not installed
   native-run  : 1.3.0


   ios-deploy : 1.11.3
   ios-sim    : 8.0.2
   NodeJS     : v14.15.4 (/usr/local/bin/node)
   npm        : 6.14.10
   OS         : macOS Big Sur
   Xcode      : Xcode 12.3 Build version 12C33