iOS not updated on build

I am not sure if this is a capacitor question or Xcode question. In localhost on web, I am seeing all the updated UI. When I build for mobile purposes, I do not see any changes.

Following:

  • ionic build
  • npx cap copy ios (also tried npx cap sync iOS)
  • npx cap open ios

When I look at the public folder under iOS app/public to search my update, I can see the changes in main.js file.
Yes, I cleared build folder under product. I also restarted Xcode. I also removed app on physical device and also tried on different simulators. Nothing changed.

Xcode version: 12.4
ionic 6.12.4

getting a bit frustrated with this, has been weeks.
So I just tried going into the iOS folder and do pod install, it worked the first time around. (Also surprised why cap sync didn’t “install”) After the following build, it reverted back to old version on next sync.

in case anyone runs into this trouble.
You need to delete the iOS folder and restart everything, it seems. This isn’t great though since all the configuration I had under iOS gets removed. So do keep a copy/reference of your old files.

Hmm this doesn’t seem right…I can’t replicate this on my end with a testing project.

  • ionic start my-app tabs
  • ionic build
  • ionic cap add ios
  • ionic cap sync ios

Then run/build the project

I make a change to anything in my typescript…

  • ionic build
  • ionic cap sync ios

and the code is updated in xcode/device/sim.

Am i missing anything?

Thanks. You are correct and that’s also what I was doing too but nothing changed. (This started happening recently.)
I honestly cannot figure out why it wasn’t updating. Deleting the folder and restarting all over was my last resort.

Can you share some more information? ionic info?

What’s your capacitor version?

I’m seeing the same thing happen with my current setup. I would rather not delete my iOS folder and restart this so I was wondering if you figured out where some files may be cached.

It’s like the JavaScript files are not being updated on new native builds to the device.

Once you deleted the iOS folder did your builds work correctly going forward?