iOS framework from Cocoapods



I am trying to get a cocoapods framework “Alamofire”

My config.xml has already it added:

<platform name="ios">
    <framework src="Alamofire" type="podspec" spec="~> 4.4" />
    <plugin name="cordova-plugin-add-swift-support" spec="~1.6.2" />

It build me a Podfile:

platform :ios, ‘7.0’

target ‘platform’ do
pod ‘Alamofire’, '4.4.0’

As I understood I must manually do pod install to get the framework into my project.

[!] Unable to satisfy the following requirements:

  • Alamofire (= 4.4.0) required by Podfile

None of your spec sources contain a spec satisfying the dependency: Alamofire (= 4.4.0).

You have either:

  • out-of-date source repos which you can update with pod repo update.
  • mistyped the name or version.
  • not added the source repo that hosts the Podspec to your Podfile.

Note: as of CocoaPods 1.0, pod repo update does not happen on pod install by default.

Did anyone encounter this problem?

As found here:

_Paired with type=“podspec”, this is the spec string for the CocoaPod you want to install (static library only). CocoaPod support only exists in cordova-ios 4.3.0 and cordova-cli 6.4.0. For your plugin, make sure you add the appropriate tags and package.json dependencies to ensure backwards-compatible support.

Is a newer cordova-ios and cordova-cli working? I am having 4.4.0 and 7.0.0 right now. In my oppinion this is working as I was able to create the podfile.

Also, is there any possibility to not manually say pod install?

Thank you!

Ionic CocoaPods

It seems that Alamofire must have minIosVersion 10.0 to be able to install.
I am still having problems with generating the podfile from config.xml so that the minIosVersion is 10.0