Ionic CocoaPods

#1

Hi,
how can i add CocoaPods to my ionic project?
Or is it possible to add this to ionic cli or ionic app scripts?

sudo gem install cocoapods
pod repo update
#2

If you’ve installed the gem, take the following steps if necessary:

Go to your platform/ios folder, then check if there’s a podfile. If there is, you shouldn’t have to do anything. If there isn’t, run pod init. It will create a PodFile for you. Inside the PodFile, add the pods you need. Now runpod install on your commandline, open yourproject.xcworkspace and run your project.

What do you need it for may I ask?

3 Likes
#3

I am having a similar problem. Can you also take a look here to give me a hint, please?

#4

i am getting you can’t run Cocoapods as root.

#5

same problem here.

how do you fix???

If I run without sudo I get “you dont have permission”.

If I run with sudo I get “you can’t run Cocoapods as root”

So???

#6

Same Problem. Did anybody find the solution? Please share.

Thanks,

#7

Does this answer help?
It’s not the exact problem but might be similar…