The sandbox is not sync with the podfile.lock


I am facing an Error(screenshot attached)
when i tried to build Hybrid IOS code using “cordova build iOS” - when i removed “push plugins” from ionic code that time working properly.

any help appreciated.

Hello Friends,

I have posted above query 7 days ago i have’t got any help till now. please do replay soon to the query,if some one of you have already faced slimier issue earlier any help is appreciated .

I’m getting the same error. Does anyone have any idea why cocoapods doesn’t work with ionic, or how to get cocoapods to work with ionic ios builds?

Did you manage to fix this?

I solved it by,

sudo gem install cocoapods,
pod setup and then go to your ios folder and run pod install.

1 Like

I’m having the same problem and I can not solve it.

PhaseScriptExecution [CP]\ Check\ Pods\ Manifest.lock /Users/easychurch/Library/Developer/Xcode/DerivedData/EasyChurch-gxkkxowhnaxudrfffwtdolwqcbfn/Build/Intermediates.noindex/EasyChurch.build/Debug-iphoneos/EasyChurch.build/Script-1BE53AB6687FE2613EDCF21B.sh (in target: EasyChurch)
    cd /Users/easychurch/projetos/ionic/mobile/platforms/ios
    /bin/sh -c /Users/easychurch/Library/Developer/Xcode/DerivedData/EasyChurch-gxkkxowhnaxudrfffwtdolwqcbfn/Build/Intermediates.noindex/EasyChurch.build/Debug-iphoneos/EasyChurch.build/Script-1BE53AB6687FE2613EDCF21B.sh

diff: /Podfile.lock: No such file or directory
diff: /Manifest.lock: No such file or directory
error: The sandbox is not in sync with the Podfile.lock. Run 'pod install' or update your CocoaPods installation.```