Ios build but no open app - using capacitor

**I built iOS using Capacitor, but when I run it in the emulator, the app doesn’t open.
Xcode 15

can you show your code / logs / errors?
otherwise it’s impossible to say what is going on.

**The app freezes on the initial screen, even though it builds successfully. It works in TestFlight, but not in the emulator, Apple review or emulating in physical device

still not helpful,
we need to see your configuration and your console, in case of errors

thats build console

I have this same issue but it reflects only on device in the TestFlight app. Emulators run without error.

No errors in Xcode, console(s) or emulators so I thought I’d come here for advice.

Capacitor deps are up to date as of writing: ^5.0.0

iPhone 12PM iOS 17.0.3 / MBP Sonoma 14.0 / Xcode 15.0 / Cocoapods 1.13.0 / Angular 15

	"appId": "",
	"appName": "name",
	"webDir": "dist/my-app-mobile",
	"bundledWebRuntime": false,
	"ios": {},
	"plugins": {
		"SplashScreen": {
			"launchAutoHide": false,
			"androidSplashResourceName": "splash",
			"showSpinner": false,
			"splashFullScreen": true,
			"splashImmersive": true
		"CapacitorCookies": {
			"enabled": true

Any ideas would be very appreciated. Thanks,