Ios 11 - Select dropdown issue

Using xcode 9 and ios 11. The select drop down has a weird behavior, when clicking sometimes an empty list appear. When clicking multiple time on the select input the application crash with this error :

[Warning] Application tried to represent an active popover presentation: <UIPopoverPresentationController: 0x7fc187b46510>
*** Assertion failure in -[UITableView _createPreparedCellForGlobalRow:withIndexPath:willDisplay:], /BuildRoot/Library/Caches/
[FATAL] [WORKLIGHT] Uncaught Exception: UITableView dataSource is not set
*** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘UITableView dataSource is not set’

This is a simple select inpu component :

<select class="defect-select" name="pageItem" ng-model="maintLog.pageItem" ng-options="item in itemsList" ng-required="maintLog.pageNo" ng-change="pageItemFocus()">
                <option value="">Select...</option>

It was working fine with ios 9 and 10.

1 Like

I’m also having this issue. I’m getting more or less the same error.

2017-09-28 10:53:05.973675-0400 MyApp[528:174782] [Warning] Application tried to represent an active popover presentation: <UIPopoverPresentationController: 0x14dd64dd0>
2017-09-28 10:53:05.985786-0400 MyApp[528:174782] *** Assertion failure in -[UITableView _createPreparedCellForGlobalRow:withIndexPath:willDisplay:], /BuildRoot/Library/Caches/
2017-09-28 10:53:05.987829-0400 MyApp[528:174782] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'UITableView dataSource is not set'
*** First throw call stack:
(0x186d33d38 0x186248528 0x186d33c0c 0x1876c2c24 0x190479820 0x190479a50 0x19048361c 0x19026e540 0x19026e400 0x19068689c 0x190464b10 0x1904650bc 0x1903402e8 0x190765ff0 0x19015c5bc 0x19015c330 0x190489f80 0x1903b4680 0x1903a7b24 0x190136808 0x186cdb8b8 0x186cd9270 0x186cd982c 0x186bfa2d8 0x188a8bf84 0x1901a7880 0x1005259f0 0x18671e56c)
libc++abi.dylib: terminating with uncaught exception of type NSException

Using this code:

<select ng-model="ctrl.currentInspection.facilityID" class="fac-select" ng-blur="ctrl.updateAutoSave()">
  <option value=""></option>
  <option ng-repeat="facility in ctrl.facilities track by facility.facilityID" ng-selected="facility.facilityID === ctrl.currentInspection.facilityID"
1 Like

Seems like it is not an ionic or cordova issue.
It is more on apple UIView side. I tried to rebuild the application using Xcode 9.1 beta, and seems like the bug is fix.

I also remember seeing an issue about dropdowns in iOS 11 on the Cordova issue tracker that was closed because it is a Webview, so Apple, bug.

Tried using XCode 9.1 Beta just now. It’s not crashing anymore, but I’m getting a double pop on my select still.

and using iOS 11.0.1 do you still have it ?

I do. I can try again in a couple of hours when I have the time and get back to you.

Yeah, still having the same issue. I tried clearing out everything and re-installing cordova, ionic, etc. I’m currently just telling my users to not upgrade to iOS 11.

Could you implement the select using an ionic modal?

It is not working for me either… weird, i thought it was when i tested it. Maybe I messed up.
Could people fill up a bug report at Apple So that the bug reach out to them. I already filled up one on my side…

1 Like

I am also facing this issue. Though using Xcode8 (instead of xcode9) solved this problem but its not a long term solution. Any long term solution?

Facing the same issue. Can the ionic team please provide a fix? There is problem with the Date field as well, cannot clear it.

As mentionned this is not an ionic Issue, but the native UIWebview component (Apple issue).
A workaround for now is to build your app using Xcode 8 or integrating the WKWebview plugin.

Facing the same issue including the date field issue as well. please provide the solution ASAP.

Did you read any of those posts before you?
Also: Your tone is not appropriate. Please change it ASAP.

1 Like

This issue is solved with the latest version of xcode 9.2 !

Still having the same issue with xcode 9.2

I was also seeing this issue. Updating to xcode 9.2 did not solve this for me. However, updating the device to iOS 11.2.5 solved it. Now my builds with xcode 9 seem to be working fine! If you are feeling up to it, and can be sure that your users will update to the latest iOS on their devices, update away.

Good luck to all of you!