iOS 11 app icon not work


#1

Hi guys,

I have a very frustrating problem, I have an app, generated with ionic 3 cli, that work perfectly on Android and iOS 12 but on iOS 11 the app icon not work.
Instead of my custom icon I have a blank iOS app Icon.

You can reproduce the issue following these steps:

run some ionic cli command to create and build a sample app:

ionic start myApp tabs
ionic cordova platform add ios
ionic cordova resources ios
ionic cordova build ios

Now open the project in xcode on a mac, then build and run on simulator iPhone 6 Plus iOS 11.3 .

If you build and run the project on simulator iPhone 6 plus iOS 12 it works.

I have tried all solution proposed here with no success: https://stackoverflow.com/questions/46109835/app-icons-not-included-in-build-from-xcode-9

I’m using xcode 10 beta.

Any help is appreciated, thanks.

Umberto


#2

It is probably a bug of Xcode v10 beta, try with Xcode v9

I work with Xcode v9, I don’t face the problem. I tried Xcode v10 beta and I noticed the similar problem


#3

The culprit was xcode 10 beta, I downgraded to xcode 9.4.1 and now the icon appear correctly.

Thank you very much @reedrichards !


#4

I disconnected the simulator from the xcode and opened the app again in the simulator, then i am able to see the icons as well.