Ios app icon doesn't show when run from command line


#1

hi everyone :smiley:

I created a custom icon with “ionic resources”, but when I type “ionic run ios” it still shows the default icon on my iPhone device.

But when I run the ionic project from XCode, the custom icon displays correctly.

Is this expected behavior? Is there anything I can do to fix it? I’d rather use ionic’s CLI.

Thanks!


here’s my “ionic info”:

(I’m actually on macOS Sierra, idk why it says El Capitan)

Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-beta.11
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1
ios-deploy version: 1.9.0
ios-sim version: 5.0.8
OS: Mac OS X El Capitan
Node Version: v6.6.0
Xcode version: Xcode 8.0 Build version 8A218a

#2

I think you need to place the custom icon in the /resources folder with icon.png name and then tried to run ionic with run ios command.

Let me know incase of any query/concern for the same.


#3

I had exactly the same problem. I managed to fix it by running:

ionic run ios --device


#4

THAT WORKED! THANK YOU SO MUCH! :grinning: