Ionic start myApp tabs not working


I just started using ionic. I did sudu npm install -g cordova ionic gulp bower and then did ionic start myApp tabs. Its creating a folder with name myApp and then creating a folder named “ionic-app-base-master” and a file named “ionic.project”.
Can you please let me know if this is expected behavior.

I did cd myApp and then cd ionic-app-base-master and did ionic platform add ios. which i ran on emulator. It shows blank app.

Can you please help


Why are you doing gulp bower?

You should be able to just do this :

> npm install -g cordova ionic
> ionic start myApp tabs

Then, you’ll have a “myApp” directory that looks like this:


I did npm install -g cordova ionic and ionic start myApp tabs.

On windows i see the folder structure you mentioned but on mac i see a folder named “ionic-app-base-master” and a file named “ionic.project”.


That’s really unusual. I’m on Mac as well.

Can you start a new one like ionic start myAppAgain tabs and capture all the output to a file including an ls of the directory that is created ? Then post it here?

There was an issue with my mac installation. I did a reset and it worked.


I tried to this command on ubuntu 13.10, but it doesn’t seem to be working.

test:~/js/test$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 13.10
Release:	13.10
Codename:	saucy
test:~/js/test$ ionic start myApp tabs
test:~/js/test$ ls -l
total 0

Can someone help me?


I have the same issue on mac:

ionic start myAppAgain2 tabs
Running start task...
Creating Ionic app in folder /Users/jbolila/wip/phonegap/ionic/myAppAgain2 based on tabs project


and the result is the blank template, not the tabs:

ls -rR myAppAgain2/
ionic.project         ionic-app-base-master

www          scss         plugins      platforms    package.json hooks        gulpfile.js  config.xml

lib        js         index.html


fonts css

ionicons.svg ionicons.eot

ionic.min.css ionic.css






I can add the platform, build and run the ios emulator, but is always the blank project.



Can y’all try updating Ionic CLI just to make sure that is not the problem?

> sudo npm update -g ionic

You should get something like this with a proper “tabs” app:

JN-MBP:ionicSamples jn$ ionic start forum3205_cli_issues tabs
Running start task...
Creating Ionic app in folder /Users/jn/Documents/Apps/ionicSamples/forum3205_cli_issues based on tabs project


Initializing cordova project.
Fetching plugin "org.apache.cordova.device" via plugin registry
Fetching plugin "org.apache.cordova.console" via plugin registry

Your Ionic project is ready to go!

Some quick tips:

 * cd into your project: $ cd forum3205_cli_issues

 * Add a platform (ios or Android): ionic platform add ios [android]
    Note: iOS development requires OS X currently
    See the Android Platform Guid for full Android installation instructions:

 * Build your app: ionic build [platform]

 * Simulate your app: ionic emulate [platform]

 * Run your app on a device: ionic run [platform]

 * Develop in the browser with live reload: ionic serve

For more help, visit the Ionic docs:
JN-MBP:ionicSamples jn$ cd forum3205_cli_issues
JN-MBP:forum3205_cli_issues jn$ ls -la
total 48
drwxr-xr-x  13 jn  staff   442 May  1 07:29 .
drwxr-xr-x  35 jn  staff  1190 May  1 07:29 ..
-rw-r--r--   1 jn  staff    14 May  1 07:29 .gitignore
-rw-r--r--   1 jn  staff  2024 May  1 07:29
-rw-r--r--   1 jn  staff   810 May  1 07:29 config.xml
-rw-r--r--   1 jn  staff   620 May  1 07:29 gulpfile.js
drwxr-xr-x   4 jn  staff   136 May  1 07:29 hooks
-rw-r--r--   1 jn  staff    89 May  1 07:29 ionic.project
-rw-r--r--   1 jn  staff   253 May  1 07:29 package.json
drwxr-xr-x   3 jn  staff   102 May  1 07:29 platforms
drwxr-xr-x   5 jn  staff   170 May  1 07:30 plugins
drwxr-xr-x   3 jn  staff   102 May  1 07:29 scss
drwxr-xr-x  11 jn  staff   374 May  1 07:29 www

I have done that before and now again.

The thing seems to come from one promise never resolved for the fetch of the on the ionic.js fetchRepo the promise isn’t resolved, the event ‘close’ never happens.

writeStream.on('close', function() {

with this the start.js starts the var repoUrl = self._getStarterUrl(repoName); but never reaches the next Ionic.fetchRepo for the requested template (tabs in this case).

I’m using the node v0.11.12 on OSX 10.9.2



I have switch to node v0.10.26 and now works fine.

Sorry, I have forgot that I’m using that dev version.



I’m having the same issue. Tried updating Ionic CLI with no luck.

drwxr-xr-x  4 Dale  staff  136 14 Aug 22:27 myApp
192-168-1-60:Ionic Dale$ ionic start myApp2 sidemenu
Creating Ionic app in folder /Users/Dale/Ionic/myApp2 based on sidemenu project

[=============================]  100%  0.0s
192-168-1-60:Ionic Dale$ ls -l
total 0
drwxr-xr-x  4 Dale  staff  136 14 Aug 22:27 myApp
drwxr-xr-x  4 Dale  staff  136 14 Aug 22:43 myApp2
192-168-1-60:Ionic Dale$ cd myApp2
192-168-1-60:myApp2 Dale$ ls -l
total 8
drwxr-xr-x  14 Dale  staff  476 14 Aug 22:43 ionic-app-base-master
-rw-r--r--   1 Dale  staff   38 14 Aug 22:43 ionic.project

Migrating from windows to mac now gives me this issue. Never had any trouble with this using windows. And tried it on a different mac with no complains. It thus seems to be very system specific. Any help on solving it would be very much appreciated.

MacBook:Desktop tobias$ ionic info

Your system information:

OS: Mac OS X Yosemite
Node Version: v0.12.0
Cordova CLI: 4.2.0
Ionic CLI Version: 1.3.8
Xcode version: Xcode 6.1.1 Build version 6A2008a 
ios-sim version: 3.1.1 

MacBook:Desktop tobias$ ionic start app tabs
Creating Ionic app in folder /Users/tobias/Desktop/app based on tabs project

[=============================]  100%  0.0s
MacBook:Desktop tobias$ cd app/ && ls -l
total 0
drwxr-xr-x  12 tobias  staff  408 10 feb 16:23 ionic-app-base-master
MacBook:app tobias$ cd ionic-app-base-master/ && ls -l
total 40
-rw-r--r--  1 tobias  staff  1020 10 feb 16:23
-rw-r--r--  1 tobias  staff   126 10 feb 16:23 bower.json
-rw-r--r--  1 tobias  staff  1012 10 feb 16:23 config.xml
-rw-r--r--  1 tobias  staff  1353 10 feb 16:23 gulpfile.js
drwxr-xr-x  4 tobias  staff   136 10 feb 16:23 hooks
-rw-r--r--  1 tobias  staff   356 10 feb 16:23 package.json
drwxr-xr-x  3 tobias  staff   102 10 feb 16:23 scss
drwxr-xr-x  5 tobias  staff   170 10 feb 16:23 www

Finally got it working with the help of a different post by downgrading node to v0.10.32. After this reinstalling cordova and ionic with nom than solved all the issues.