Ionic serve doesn't trigger webpack

Hi everyone

When I type ionic serve command into command line, it starts the server but doesn’t boundle javascript/css files via webpack. It also figures out when some changes happen and reloads browser but without building javascript files.

I’m using javascript, not typescript.

This happend after I installed Crosswalk plugin to support older android devices on Ionic 2. In process of setting up Crosswalk I removed platform and npm_modules and reverted it back but it shouldn’t be related to this issue.
Also my other Ionic 2 project, which I didn’t touch at all, doesn’t work so it’s something global.

I’m still not so familiar with webpack. Does anybody know how I can connect ionic serve and webpack commands?

Here’s what I get when I run ionic serve:



I’ll be interested in the answer to this as I’ve run into this a couple of times and wasn’t able to resolve it until I created a new ground-up Ionic project and ported over my code…have no idea why.

I finally figured it out

While I’ve been setting up Crosswalk plugin I “updated” ionic CLI, as it was mentioned in Ionic blog post, with npm install ionic -g command. Since I work with Ionic 2 and I use ionic@beta CLI, I actually downgraded CLI which was not compatible with Ionic 2 projects any more.

In order to make this work I had to install ionic CLI again but with beta flag npm install -g ionic@beta

Works fine now.