Ionic2 RC2 serve does not work


#1

When I upgraded my Ionic project to RC2, the ionic serve command stopped working. ionic run android runs well and installs application on my connected Android device, but ionic serve is stuck after build dev finished - no error is displayed:

[09:18:15]  lint finished in 4.90 s
[09:18:15]  transpile finished in 5.94 s
[09:18:15]  webpack started ...
[09:18:16]  copy finished in 6.39 s
[09:18:26]  webpack finished in 10.76 s
[09:18:26]  sass started ...
[09:18:30]  sass finished in 3.68 s
[09:18:30]  build dev finished in 20.40 s

Please help, I can not continue my development :frowning:

Your system information:

Cordova CLI: 6.3.1
Gulp version:  CLI version 3.9.1
Gulp local:
Ionic Framework Version: 2.0.0-rc.2
Ionic CLI Version: 2.1.1
Ionic App Lib Version: 2.1.1
Ionic App Scripts Version: 0.0.39
OS:
Node Version: v4.6.0

#2

Did you update the app-scripts to latest?


#3

I have Ionic App Scripts Version: 0.0.39, as stated in the CHANGELOG


#4

might try updating to node v6.9.1, which is the current latest LTS


#5

It find it unusual that ionic build android command works, but ionic serve does not. Usually it was the other way around - due to inconsistencies in my source code.


#6

Did you update your tsconfig.json as specified in the release notes?

http://blog.ionic.io/ionic-build-process-updates/

https://raw.githubusercontent.com/driftyco/ionic2-app-base/master/tsconfig.json


#7

I did that now, but it makes no difference :frowning:


#8

Sorry to hear that. my last idea, is maybe the server port already in use or another process still running or hanging? Try to have a look and if necessary kill these tasks before trying again…maybe not sure about it


#9

I appreciate suggestions from both of you, I also tried to restart the computer so there would be no other ionic serve process occupying the port.

I have two further observations:

  1. I have another Ionic project that I have not yet updated from RC1 to RC2 - there ionic serve works with no problems

  2. When I run my RC2 project for android, it works, and it is using build prod, while ionic serve, that does not work, uses build dev


#10

I managed to get it working, problem was missing manifest.json in the src folder. I’ve seen Ionic team warning about this, but I checked one other application and the file was there, so I didn’t check the rest :open_mouth: