Ionic run ios --device get error


#1

Hi everyone:

I tried to run my ionic project in my iPhone using command

ionic run ios --device

But it failed and I got these error information:

[....] Waiting up to 5 seconds for iOS device to be connected
[....] Found iPhone 5c (Global/CDMA) 'user's iphone' (***) connected through USB.
[....] Waiting for iOS device to be connected
[....] Using iPhone 5c (Global/CDMA) 'user's iphone' (***).
------ Install phase ------
[ 0%] Found iPhone 5c (Global/CDMA) 'user's iphone' (***) connected through USB, beginning install
2015-09-23 09:17:07.556 ios-deploy[54028:507] [ !! ] Error 0xe8000008: AMDeviceSecureTransferPath(0, device, url, options, transfer_callback, 0)
Error code 253 for command: ios-deploy with args: -d,-b,/Path/to/myApp/platforms/ios/build/device/プロジェクト.app
ERROR running one or more of the platforms: Error: /Path/to/myApp/platforms/ios/cordova/run: Command failed with exit code 2
You may not have the required environment or OS to run this project

You may notice that my app name is Japanese. Yes, it is the problem. I also tried to use a Chinese app name and a Korean app name. Failed again. But when I use an English app name, it is ok both in simulator and device. Must the app name be English if I want to run my app in iOS? What should I do if I want to use a app app of other language?

Any help would be appreciated.