Ionic run ios aborted


#1

Hi !

I’m trying to run my Ionic app on my iPhone 5 (iOS 7.0.4).
The build is ok, but when the run command is launched, I catch this error, immediately after BUILD SUCCEDED :

Assertion failed: (AMDeviceStartService(device, CFSTR("com.apple.afc"), &afcFd, NULL) == 0), function handle_device, file ios-deploy.c, line 775.
------ Install phase ------
[....] Waiting for iOS device to be connected
[  0%] Found device (6d5f674fe825d9a76a74c2db7aa0156d85536bac), beginning install
/myApp/platforms/ios/cordova/run: line 138: 30116 Abort trap: 6           ios-deploy -d -b "$DEVICE_APP_PATH"

Any idea ? I’ve read all posts about ionic run ios, but nothing works for me.

Thanks all! :wink:


#2

Can you try this with just : > cordova run ios

That will help narrow down the problem.

Also:
Have you updated Ionic CLI lately? You might want to do that : > sudo npm update -g ionic

What version of Cordova are you using? > cordova -v
Node version? : node -v


#3

cordova run ios return the same error.
Yes, my Ionic CLI is up to date

cordova -v : 3.4.1-0.1.0
node -v : v0.10.26

Thanks


#4

I was able to get around the DEVICE_APP_PATH issue by doing the following steps:

  1. at the cli: cordova build ios
  2. deploy using xcode
  3. at the cli: cordova run ios

Not ideal but at least I dont have to go to xcode after the first time.


#5

I have seen that error before.
In my case, it was because of a special character in my ios .app name.

you can have a look at the code here. there is two variables that may cause problem, file name or project path:


#6

I have the same problem out of the blue!
today i tried to run mu app using: ionic run ios and got the same error.
Also tried: cordova run ios - same error.
node v0.10.28
cordova 3.5.0-0.2.4

My app name is EmpDirApp so there are no special characters.

Any thoughts?


#7

I think this is ios-deploy’s issue. Here is the hithub issue: