Ionic requires what version of Android tools?

I’d like to write an Ionic app for Android 4.1.2 and up (API 16). What version of Ionic should I use?

And is there a chart somewhere that correlates Ionic versions to minimum Android and iOS versions?

Thank you.

I have the latest Ionic framework installed (1.0.0-rc.5), with the latest command line tools (1.3.22).

I changed AndroidManifest.xml to have the following:

<uses-sdk android:minSdkVersion="16" android:targetSdkVersion="16" />

I changed to have the following:


When I attempt to use ‘ionic run android’ I get the following as the first of a list of errors during the build stage:

C:\Users\Matt Merrill\Documents\Cordova     Apps\BRILoonyBin\platforms\android\CordovaLib\src\org\apache\cordova\ cannot find symbol
symbol  : class ClientCertRequest
location: package android.webkit
import android.webkit.ClientCertRequest;

When I check out that class in the Android docs ( I see the notation:

Added in API level 21

Which leads me to believe that ionic is not honoring my request to use android-16. Or maybe cannot do so, perhaps because the version I’ve installed can’t target such an “old” version of Android.

Or something. Anyone have any pointers about what I’m doing wrong?

Im guessing your changes in the Android manifest are probably being overwritten. Perhaps you could configure that either in config.xml or by using a hook script.

I had some issues at the beginning, make sure your app runs in ionic serve on the browser, then I had to change the version of my device to an android 4.4 API 19 I was using a 4.1 api 16 ; so I was able to debug on the device, if you don’t have a device you should try the genymotion emulator and add an emulator with the 4.4 version and API 19

I have the same issue.Anyone can explain this?

Referenced from

I have resolve this by upgrade my sdk version to API 22.It worked! But still Thank you for your information.