Error build ionic Android API 10


#1

I found problems when compiling my project ionic/cordova (6) , looked in AndroidManifest.xml(platforms\android) and is setted correctly.

In AndroidManifest.xml(platforms\android\build\intermediates\exploded-aar\android\CordovaLib\unspecified\debug) I attribute minsdk 10 but when I build the project it overwrites 14

I add on my config.xml preference name=“android-minSdkVersion” value=“10” but not work…

I add on my manifest tools:overrideLibrary but not work…

Manifest merger failed : uses-sdk:minSdkVersion 10 cannot be smaller than version 14 declared in library [android:CordovaLib:unspecified:debug] D:\XX\platforms\android\build\intermediates\exploded-aar\android\CordovaLib\unspecified\debug\AndroidManifest.xml
1>      Suggestion: use tools:overrideLibrary="org.apache.cordova" to force usage
1>
.....................
1>
1>  * Try:
1>  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
1>MDAVSCLI : Java HotSpot(TM) 64-Bit Server VM warning : ignoring option MaxPermSize=512m; support was removed in 8.0

#2

Ionic does not support running on older versions of Android due to the poor performance of the webview on those older devices.


#3

Hello!!! I understand that the IONIC no support for versions older but says it works


#4

I found the solution alter manifest in : platforms\android\CordovaLib