Ionic prepare is not working


#1

I’m working in my /src folder. The browser shows me all changes I made perfectly, but ionic prepare -ios or ionic cordova prepare -ios (and re-run app in Xcode) has no effect at all. I can’t get code changes on my iOS device.

I was working with cordova before and the cordova prepare ios command was working fine for me. Is there a different workflow for ionic or am I doing something wrong?


#2

Same for me. Just realized while debugging. I’m going mad!


#3

Downgraded to Ionic CLI v2 but problem stays the same. Only workaround I have atm is to run $ionic run ios. It throws me an error but the platform folder is updated


#4

ionic prepare is not a command with CLI v3.
It is ionic cordova prepare now: https://ionicframework.com/docs/cli/cordova/prepare/


#5

As I said, $ionic cordova prepare is not working either


#6

In your first post you have a - in front of ios. The correct command would be ionic cordova prepare ios, which does a bit of Ionic stuff and then just executes cordova prepare ios in the background.

If this also doesn’t work, please paste the complete output of the command you get.[quote=“felixks, post:3, topic:93307”]
It throws me an error but the platform folder is updated
[/quote]

What error are you getting?


#7

So if I run this there is no error, it’s says :heavy_check_mark: Running command - done! But the code is not updated

If run ionic cordova run ios:

Starting debug of a0a6cd09d60cb9b18d134b337722f786414e0047 (N61AP, iPhone 6 (GSM), iphoneos, arm64) a.k.a. 'Felix' connected through USB...
2017-06-20 11:50:59.725 ios-deploy[34254:13792008] [ !! ] Unable to locate DeviceSupport directory. This probably means you don't have Xcode installed, you will need to launch the app manually and logging output will not be shown!
Error: Error code 253 for command: ios-deploy with args: --justlaunch,--no-wifi,-d,-b,/Users/Documents/dev/amsysionic/platforms/ios/build/device/Amsys.app

#8

Run ionic cordova prepare ios --verbose please.


#9
[DEBUG] Loading global plugin @ionic/cli-plugin-proxy
[DEBUG] Loading local plugin @ionic/cli-plugin-cordova
[DEBUG] Loading local plugin @ionic/cli-plugin-ionic-angular
> cordova prepare ios
✔ Running command - done!

but still not working…


#10

That would be a (strange) bug then. Could you please open an issue here https://github.com/ionic-team/ionic-cli/issues and include a link to this topic.


#11

Just noticed: Have you actually built your code from /src to /www? You have to call a command that runs a build like ionic serve or better npm run ionic:build (with e.g. --prod as parameter for a production build) before you can prepare /www to the platforms.