Updated Cordova, now ionic run ios can't find device

Just updated Cordova:

npm update -g cordova

Following this, ionic run ios launches the simulator and can’t find my connected device.

I’ve tried:

cordova platform update ios
removing the ios platform directory, and reinstalling ios platform using: ionic platform add ios
unplugging my iPhone, plugging back in
killing the app on the device
restarting the device

Building & running from XCode works, so the device is connected, and recognized. I’m also on the latest ionic (1.4.0-alpha.5).

Have you tried to prepare or build from cordova CLI?

“prepare” and “compile” are running okay, along with “cordova run”…but it launches on the Simulator as well.

Figured it out - had to revert to a previous version of Cordova:

npm install -g cordova@4.2.0

Maybe an issue with 4.3.0?

need to reinstall ios-deploy… that solved it for me

sudo npm install -g ios-deploy

Failing that with Cordova 4.3.0 try:

ionic run ios --device

I think this is an oddity introduced with 4.3.0 see https://groups.google.com/forum/#!topic/phonegap/QtVXVKuZKsY