Ionic + PhoneGap Build


#1

Has anyone used PhoneGap Build to build their Ionic application?
This is perfectly possible, unless I use some plugins, like the camera. PhoneGap Build doesn’t recognize the plugins and I have no idea how to fix it.

Does anyone has the same problem? Could you fix it? Or experience with PGB + Ionic?


#2

Hello,

I use PhoneGap Build for my apps and i have no issue with it.
Could you share you config.xml?
Is your plugin displayed in the “plugin” tabs on the phonegap build website?


#3

Thanks for your reply. This is my config.xml:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<widget id="com.ionicframework.xxx"
    version="0.0.1"
    xmlns="http://www.w3.org/ns/widgets"
    xmlns:cdv="http://cordova.apache.org/ns/1.0"
    xmlns:gap="http://phonegap.com/ns/1.0">
<name>APPNAME</name>
<description>
    DESCRIPTION
</description>
<author email="hi@ionicframework" href="http://ionicframework.com/">
    NAME
</author>
<content src="index.html"/>
<access origin="*"/>
<preference name="phonegap-version" value="3.7.0" />
<preference name="fullscreen" value="true" />
<preference name="webviewbounce" value="true"/>
<preference name="UIWebViewBounce" value="true"/>
<preference name="DisallowOverscroll" value="true"/>
<preference name="BackupWebStorage" value="none"/>
<preference name="Orientation" value="landscape" />
<feature name="StatusBar">
    <param name="ios-package" value="CDVStatusBar" onload="true"/>
</feature>

<gap:plugin name="org.apache.cordova.camera" source="plugins.cordova.io"/>

</widget>

The plugin is recognized by PGB in the plugin tab.

I’ve followed this: http://learn.ionicframework.com/formulas/cordova-camera/ to implement the camera function. When I build the application locally or test it via IonicView the camera function is working perfectly, but when I build it via PGB it’s not working.

EDIT: I have also copied this config.xml in my www/ folder.


#4

Try to follow the official doc with version=“0.3.2” : https://build.phonegap.com/plugins/1173

Did you include the js camera script in your index.html? (if it’s case, the script will be in conflict with the script injected by phonegap build)


#5

Yes, I also tried to use:

<gap:plugin name="org.apache.cordova.camera" version="0.3.2" />

But also no results. I also have no js camera script included in my index.html.
Yesterday I’ve made a Stackoverflow thread about this too, with a little bit more information: http://stackoverflow.com/questions/29800585/plugins-with-ionic-phonegap-build-doesnt-work

No useful answers there.


#6

I didn’t see at the the first read but <feature name="http://api.phonegap.com/1.0/camera"/> is missing in your config file?

Full example here : http://docs.build.phonegap.com/en_US/2.9.0/configuring_features.md.html#Features


#7

Well I tried different combinations as stated in the stackoverflow thread, but I can’t seem to get it working. Do you also use the camera plugin? (I also use the network-information plugin, but same story)


#8

No, I have used geoloc and device plugins without any issue.
I will send you my config file by PM


#9

Thanks, that would be nice!