Ionic Package: iOS build fails

When building my app for iOS using ionic package, the build fails with the following error:

=== BUILD TARGET <AppName> OF PROJECT <AppName> WITH CONFIGURATION Debug ===

Check dependencies
Signing for "<AppName>" requires a development team. Select a development team in the project editor.
Code signing is required for product type 'Application' in SDK 'iOS 10.0'

** BUILD FAILED **

This happened the first time today. Before I was using ionic 2 beta 11, and it was always working. Now, first time with ionic 2 RC 0

EDIT: Since September 29, the build error disappeard, but after the splash screen the app shows only the default APACHE CORDOVA logo.

SOLVED: Seems to be solved now (2016-10-05)

3 Likes

I had the same issue today with a different version of ionic, here’s the output from running ionic info for me.
Cordova CLI: 6.1.1 Ionic Framework Version: 1.2.4-nightly-1917 Ionic CLI Version: 2.0.0 Ionic App Lib Version: 2.0.0-beta.20 OS: Distributor ID: Ubuntu Description: Ubuntu 14.04.3 LTS Node Version: v4.4.0

I was able to get a build created, it had the correct icon, name, and splash screen. But when I loaded the app, it showed a box creature image (cordova logo) and said APACHE CORDOVA below that in a flashing green box says DEVICE IS READY

Just three days ago I was creating successful builds with the same profiles as I am using now. I know my profiles don’t expire for another eleven months since I just updated it last month.

Happened to me too.

My last build was at 2016-09-29 4:43 PM today, builds after then all failed with above message, this is ionic 2 beta 10 btw, but doubt the version makes a difference

did you open xcode manually and set the team / certificates?

This is using ionic package, not a local build

1 Like

I’m not getting the build error any more, but the builds I am getting still have that cordova logo and none of my code.

2 Likes

Same here. Build is successful, but contains only the cordova logo.

Me too facing the same issue. Using beta.11 and getting codova logo and can’t proceed after that.

builds are working as usual for me now…

Same issue here.

I 'm able to get a build, it has the correct splash screen but after splash it shows APACHE CORDOVA logo and below that in a flashing green box says DEVICE IS READY.

1 Like

I have the same issue using beta.11 and building through Ionic Package (online build).

I deploy the ios IPA file to iTunes Connect and then in TestFlight the app shows the splash but then stops at the Cordova Device Ready screen.

I am updating to rc0 at the moment to see if this solves the issue.

I get the issue still after updating from beta11 to RC0.

This is really a major issue for me/my customer since we are about to go into production (submit to Apple App Store) and now we can’t because of this since we are depending on the cloud builds to work.

I understand that some issues are to be expected during beta/rc development but this is a complete show stopper for us.

Just to clarify: The app works with Ionic serve, it works in the ios Emulator and it works in Ionic Viewer. But the cloud build does not work when deployed through Apple TestFlight (it displays the splash and then the Cordova default page shows with the Device Ready text).
I have tried to rollback to a previous version that worked just one week ago and building that again (cloud build) however that also fails now so the issue must be with the ionic cloud package server).

You can emulate.

  1. change package.json's scripts:build. add --dev.

“scripts”: {
“build”: “ionic-app-scripts build --dev”,

  1. doionic emulate ios.

  2. open ionic2 project file use Xcode. (after ionic emulate ios)

  3. open “General” and change Signing => Team (under this image)

and run build.

but this method can’t run emulate -l/

regards.

1 Like

Hey all, we’re looking into this. It appears to be related to iOS 10 rather than any specific Ionic framework version.

Can you all share your Ionic CLI version? If you’re running on the beta channel, try npm uninstall -g ionic and then reinstall: npm install -g ionic

Hey everyone, here’s the deal: iOS 10 builds are not yet working on Ionic Package. We’re waiting on a patch on the Cordova side before we can get these done, since it needs a flag for the new X Code developmentTeam flag. We’re tracking that here: https://issues.apache.org/jira/browse/CB-11845

In the meantime, we’re working on ways to get this working and will have it up with an announcement when it’s ready.

For now, release builds for iOS can be done on a Mac, either from X Code or by following this guide: https://dpogue.ca/articles/cordova-xcode8.html

Sorry for the trouble and please stand by.

1 Like

Hi, I might be shooting a noob question here, but can you please explain what does an “iOS 10 build” exactly mean?

TL;DR
Application gets stuck on cordova screen flashing:

Device Is Ready

I mean, this is my very first time undergoing the perplexing procedure of generating iOS certificates…

I tried to build a very simple application on Windows 10 x64 using ionic 2RC0

Ionic Framework Version: 2.0.0-rc.0
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1
OS:
Node Version: v6.6.0

next, I did

ionic upload

after that, I generated all the certs on mac osx Sierra and created a profile in Security Profiles & Credentials naming it “dev”

after that:

ionic package build ios --profile dev

in the ionic app, there is Success

next, I downloaded IPA and synced it to a iOS9 iPhone (hence my question about an iOS 10 build).

finally:

Device Ready

and that’s just about it

Just before I found this post, I kicked off an iOS10 update on the device

hmm, thanks for the info. Sharing this w/ the cloud team to look into. Stand by…

I 'm able to get a build, it has the correct splash screen but after splash it shows APACHE CORDOVA logo and below that in a flashing green box says DEVICE IS READY.

Any Updates regarding this issue …

yes i have same problem

just came by this thread:

I can confirm that the generated IPA (which i realized can be unzipped) did not contain the application itself in the /www

1 Like