Ionic serve reload too frequently


#1

Hi,
I’m coding on Win 7
When I want use ionic serve that start this line :

Starting app-scripts server: --port 8100 --p 8100 --livereload-port 35729 --r 35729 --address 0.0.0.0

But it’s impossible to see screen because the reload too frequently !

If I add --nolivereload parameter the line change but at the beginning not at the end !

How to change parameters or how not to have too frequently reload ?

Thanks by advance.

with ionic info command I obtain

global packages:

@ionic/cli-utils : 1.5.0                                                          
Cordova CLI      : 7.0.1                                                          
Ionic CLI        : 3.5.0                                                          

local packages:

@ionic/app-scripts              : 2.0.0                                           
@ionic/cli-plugin-cordova       : 1.4.1                                           
@ionic/cli-plugin-ionic-angular : 1.3.2                                           
Cordova Platforms               : android 6.2.3                                   
Ionic Framework                 : ionic-angular 3.5.0                             

System:

Node       : v8.2.1                                                               
OS         : Windows 7                                                            
Xcode      : not installed                                                        
ios-deploy : not installed                                                        
ios-sim    : not installed                                                        
npm        : 5.1.0

#2

What does that mean?

What does that mean?
What is the output on the command line? Does it build and rebuild all the time?


#3

Yes, it build and rebuild all the time.


#4

Then porbably something is changing files in your project directory, which the CLI catches and triggers rebuilds. Any idea?


#5

line with my --nolivrereload parameter :
Starting app-scripts server: --nolivereload --port 8100 --p 8100 --livereload-port 35729 --r 35729 --address 0.0.0.0


#6

Yeah what does that mean? The CLI just outputs the parameters in a different order, that is quite normal.
Does it actually disable livereload?


#7

What editor? Could it be auto-saving?


#8

We have the same effect on windows with angular 2. We use this line to have no problem
ng set --global defaults.poll 2000

but what to do for ionic serve ?


#9

That is a workaround that I don’t think exists for Ionic. You should fix the base problem.


#10

I have the same problem,
@Sujan12 , @devrap_lyon ¿Have you solved it?
I think that Chrome is the problem. The command ionic serve starts to build and rebuild after I opened Chrome.
¿Someone know how to solve this?


#11

You use webstorm? That editor got auto-save default


#12

it happens the same using firefox for example?


#13

I dont use webstorm, I use Visual Studio Code and I have the auto save propertie set to false.
I am not sure about Chrome being the problem.
I have tried to close all programs and execute ionic serve --no-open and it works fine. I had oppened all programs one by one, I have started VS Code (All fine), Chrome (all fine), and when I oppened Smartgit Ionic started the build again.
¿Maybe the problem is with smargit or git?


#14

It’s a very strange error, i think it isn’t relation with ionic… Have you tried gitkraken?


#15

As @temohpab said, try another Git client like Gitkraken or Sourcetree. Also look for an option in Smartgit that could cause this.


#16

I really dont know what is happening.
I have tried with SourceTree and all was going well, but when I opened Chrome it started to reload again.
I am desesperated…


#17

What is the exact command you are executing on the command line?
In what browser are you looking at the app?
Anything special about your Chrome? Addons?


#18

The command I execute is “ionic serve”.
I am looking at the app in Chrome version 62.
I am using windows 10.
I have disabled all extensions except Symantec Extension.


#19

Try disabling this one and see if it fixes the problem.


#20

I can’t disable this one because it is blocked by my company.