Ionic lab: blank screen

Hi,

I worked on a simple project using Ionic 3 and Angular. I completed it and it worked fine with Ionic lab. However 2 weeks later (now), I ran ionic lab on that project and it just gives me a blank screen when the browser opens. The console gives the following error:

SEC7112: Script from http://localhost:8200/build/app/app.a2co6gra.js was blocked due to mime type mismatch

I have uninstalled cordova and ionic and installed them again, but they didn’t work.

What is this a2co6gra.js and how can I fix the issue please?

I searched and read the following answers but I can’t follow them and they don’t seem to be relevant to this: here and here

Thank you.

Could you share more info please?

cordova plugin list

and

ionic info

would be a good start.

Hi,

Sorry.
Here is the Ionic version:
image

For the cordova plugin list, it keeps saying “Current working directory is not a Cordova-based project.” even though I have cordova installed globally.

I created a new blank project and the message changed to:
“Script from http://localhost:8200/build/app/app.wb3f8tpj.js was blocked due to mime type mismatch”

Thank you.

I did some research and I have a few things in mind. First try adding a platform with the --verbose flag

ionic platform add android --verbose

Paste here the output so we can rule out a few things. Then make sure you have ‘www’ folder in the root folder of your project. If you dont have it just create it

mkdir www

Hope this works!

Thanks for that. I didn’t have a www folder so created it. I also added the platform but it didn’t work.

I went through the drastic route of uninstalling ionic, cordova, angular, npm and node and then installing them again. It made no different. What I then did is just do ionic serve and then manually type ionic-lab at the end of the address in the browser. It seems to work cur

1 Like