Ionic iOS APP stuck on splashscreen with loading indicator


#1

I am getting the attached error message from xcode whenever I try to run my ionic 3 project on simulator ios 11. May I know if there is anyone else getting same issue? I created a new project with blank starter template, still getting the same error message. it works well on android and browser for same set of source code

So far I have tried - but getting same error .
ios 11
ios 9
reinstall xcode

steps to replicate
ionic cordova start testios blank
ionic cordova platform add ios
ioinc cordova build ios --prod --release
use xcode from xcodeproj generated and try to run with your simulator

Ionic Info

cli packages: (/usr/local/lib/node_modules)

    @ionic/cli-utils  : 1.18.0
    ionic (Ionic CLI) : 3.18.0

global packages:

    cordova (Cordova CLI) : 7.1.0

local packages:

    @ionic/app-scripts : 3.0.1
    Cordova Platforms  : ios 4.5.3
    Ionic Framework    : ionic-angular 3.8.0

System:

    Node  : v8.9.1
    npm   : 5.5.1
    OS    : macOS High Sierra
    Xcode : Xcode 9.1 Build version 9B55

Environment Variables:

    ANDROID_HOME : not set

Misc:

    backend : pro

#2

Same issue for me also.


#3

Did you fix this issue ?


#4

Some fix about this?


#5

I had the same issue, spent a lot of time on it and finally fixed it by resetting my /etc/hosts file that was corrupted.
My localhost was not there anymore.
I set it back to:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1       localhost
255.255.255.255 broadcasthost
::1             localhost
fe80::1%lo0     localhost

Hope it helps…