Ionic does not recognize Android 5.1


#1

Hi there,

I tried to deploy my app on a friends 5.1 android phone and it incredibly failed.
I used the same ionic run android command that I used for a 4.4.2 phone which worked but it did do nothing.
The ionic run command did not recognize the phone that was connected through USB but it started the emulator.

Any ideas why it runs with 4.4.2 and not with 5.1?
Do I need to compile it towards the special version number somehow?

EL


#2

what os do you running?
On windows you need to install the correct usb-drivers for that device first.


#3

OSX 10.10.4
ionic 1.5.0


#4

And what devices do you have with Android 4.4.2 and 5.1?


#5

4.4.2 - Moto G
5.1 - LG ???


#6

strange… i tested this with moto G (2) android 5.0.2 and sony xperia z3 compact (5.1.x) and moto X with latest android release.

Maybe there are problems with LG-devices like i have with Samsung devices (i can not debug any of them)


#7

Ok, I don’t need debug, I need deploy :slight_smile:
I will try to compile a downloadable package and get it online.


#8

If you are running google chrome can you remote debug that device?

or if you have the adb-tools installed, you could run “adb devices” in a terminal to get the devices detected.


#9

Don’t have it here anymore :frowning: can’t tell


#10

Ok, here are the specs:

LG G3 running Android 5.0.1, Kernel 3.4.0

It was 5.0.1 and not 5.1


#11

What do you see when running adb devices?


#12

I just upgraded from 4.4 to 5.1. I didn’t have any issues other than the navbar text is spaced differently. I’m running on Samsung Note 3. Make sure you upgrade all of your libraries, including cordova.


#13

Oh. I’ve seen this too. I had to go into the debug settings on the phone and re-enable USB debugging. Then try restarting the device, machine, and run ‘adb kill-server’ and ‘adb start-server’.