Deployed to AppStore, but subsequent versions do not deploy


#1

Using Ionic 3.19.0, I successfully deployed an app to the App Store and had it approved a couple of weeks ago.

But subsequent attempts to deploy later versions to Test Flight all end up showing that old UI. Later versions work fine on local simulations and on my iPhone connected to the Mac. I bump the version number in config.xml each time and run

ionic cordova build ios --release -prod

then archive.

Have spent a few days on it and am pulling out my hair. Which I can’t afford to do at my age.

Any clues welcome.


#2

Define “old UI”. The UI that is currently live?

Are you using Ionic Deploy?

What is your ionic info output?


#3

Thanks for considering my question.

Yep, I meant the UI that is currently live.

(master)]$ ionic info

cli packages: (/Users/guy/.nvm/versions/node/v7.10.0/lib/node_modules)

@ionic/cli-utils  : 1.19.0
ionic (Ionic CLI) : 3.19.0

global packages:

cordova (Cordova CLI) : 7.1.0 

local packages:

@ionic/app-scripts : 2.1.4
Cordova Platforms  : ios 4.5.4 old
Ionic Framework    : ionic-angular 3.9.2

System:

ios-deploy : 1.9.2 
Node       : v7.10.0
npm        : 2.15.12 
OS         : macOS High Sierra
Xcode      : Xcode 9.1 Build version 9B55 

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

#4

I repeat the important part of my question:


#5

No, not ionic deploy.

I’m using XCode to upload the archive to the AppStore.

It worked the first time !


#6

How are you using Ionic Pro exactly?


#7

I am not using Ionic Pro, it shows up in ionic info because I ran this command yesterday;

ionic config set backend pro -g

Then I could not find an option to undo that.

My issue was happening before that.


#8

In 99% of all cases the problem you describe is caused by people using Ionic Deploy in the background, which downloads the last published version from Ionic Pro servers on app start. If they forget to deploy the new version, or configure it incorrectly, they always see the old app.

Is Testflight correctly showing the new version and build numbers?
Is your app really this version when installed via Testflight? (There is an app list somewhere)


#9

That sounds very possible. It would fit a symptom, which is that on a few occasions, after deploying through XCode, the correct version was visible until I backgrounded it, then the out of date version appeared.

I think I need to rewatch some of the excellent videos from Ionic.

Thank you all.


#10

Yes that was the cause.

Thank you.


#11

Awesome, glad I could help.

Can you share how you got rid of it for future users with the same problem?


#12

Sure, sorry.

I logged onto my Ionic Dashboard and found the latest build, then deployed it.

Then as soon as I went back to Test Flight on my phone, that version of the app was visible. Previously some magic had fetched an old version from Ionic that I had forgotten about. Cost me days, my fault, but costly.