Ionic CLI 3 + Linux (Ubuntu) Problems


#1

I attempted to upgrade to Ionic CLI 3 for my app. It would not build then.

When I ran ionic cordova build android the errors I saw were:

> cordova build android
✖ Running command - failed!

[ERROR] Cordova encountered an error.
        You may get more insight by running the Cordova command above directly.
        
[ERROR] An error occurred while running cordova build android (exit code 1):
        
        Running command: /home/myhome/git/myapp/hooks/after_prepare/010_add_platform_class.js /home/myhome/git/myapp
        add to body class: platform-android
        Running command: /home/myhome/git/myapp/hooks/after_prepare/020_remove_sass_from_platforms.js /home/myhome/git/myapp
        Script file does't exist and will be skipped: /home/myhome/git/myapp/package-hooks/add_platform_class.js
        Error: ENOENT: no such file or directory, stat '/home/myhome/git/myapp/package-hooks/ios9_allow_http.sh'

It seemed to be hung up on there being an ios9_allow_http.sh file. Strange since I was building for android!

I created an empty file ios9_allow_http.sh with execute permissions in the package_hooks directory. Now it worked!

Just thought I’d post in case it would be helpful for anyone else.


#2

thanks i like ubuntu as server when i manage mines, it will help people later for sure :slight_smile: (i guess i was a CORS issue)


#3

I would​ try to remove android as a platform and add it again.


#4

@jsanta yes try it, sometimes, you need to fully rebuild it as for example yourproject directory ionic build ios or android then, ionic run both to have it clean of bugs