Ionic 3 - Building my app results in errors no matter what I do


#1

Hey everyone,

I’ve been struggling with trying to build my Ionic app for the last two weeks ever since I upgraded to Ionic 3

I’ve tried everything ranging from deleting my platforms folder, plugins, updating my plugins, reinstalling the platform, downgrading the CLI, ionic-app-scripts, etc. and I have no idea why I consistently keep getting this error when I run ionic cordova build ios --verbose:

[ERROR] Cordova encountered an error.
        You may get more insight by running the Cordova command above directly.

[DEBUG] !!! ERROR ENCOUNTERED !!!
[ERROR] An error occurred while running cordova build ios (exit code 1):

What command are they talking about here?

The build will actually succeed, but when I try to install it on my device, it installs it no problem, but then it just sits on the splash screen with a loading icon spinning. I’ve attached it to my safari debug tools and I get no errors there, either.

Here’s what I get when I run ionic info

global packages:

    @ionic/cli-plugin-proxy : 1.3.0
    @ionic/cli-utils        : 1.3.0
    Cordova CLI             : 7.0.0
    Ionic CLI               : 3.3.0

local packages:

    @ionic/app-scripts              : 1.1.4
    @ionic/cli-plugin-cordova       : 1.3.0
    @ionic/cli-plugin-ionic-angular : 1.1.1
    @ionic/cli-plugin-ionic1        : 1.3.0
    Cordova Platforms               : ios 4.4.0
    Ionic Framework                 : ionic-angular 3.1.1
    Ionic Framework                 : unknown

System:

    Node       : v6.9.0
    OS         : OS X El Capitan
    Xcode      : Xcode 8.2.1 Build version 8C1002
    ios-deploy : 1.9.1
    ios-sim    : 5.0.13

I’m not sure if it’s the CLI that’s causing the issue because I was able to install and run the ionic team’s conference app no problem.

I should note that this all works fine with ionic serve. Even when I do ionic cordova emulate ios, it gives me the same issue with the loading animation on the load screen.

But when I do ionic upload and view it, it at least gets to my login screen and past the loading animation. Hmmmm.

I have a number of cordova plugins I’m using, and they are all up to date. Do I need to somehow completely downgrade to a previous version of all this stuff? I’m at a loss here :frowning:

Thanks in advance!


#2

Hah! So it finally occurred to me that the Splashscreen would get stuck is because when I was upgrading to Ionic 3, I forgot to update my Splashscreen code where I’m calling this.splashscreen.hide() in my app.component.ts file

Problem solved :slight_smile:


#3

This is strange.

Could you post your package.json please?