Ionic 3 android project not building anymore

all of a sadden when i type “ionic cordova build android” I get this error, any help would be appreciated, cant say what the problem is but the same project was building just fine yesterday and I haven’t added any new plugins on anything of the sort.

this is the error i get:

Execution failed for task ‘:transformClassesWithJarMergingForDebug’. duplicate entry: android/support/v13/view/DragAndDropPermissionsCompat.class

hello, you’ll have to take the painful process of updating Java on Windows, aka go to java jre page download and make sure your windows environment variables match with folder.

good luck,

please be more specific im a bit of a noob when it comes to debugging…how do i check my enviroment and compare it to a file

Jave Runtime Environment, or just install Java for Windows again, it will update.

and then you will probably have to update your PATH in windows system / environment variables

hope it helps, that issue happened to me too,

a test you could do:

  1. open cmd.exe and type ionic
  2. type ionic -v or ionic version

and then finally try again ionic serve

ionic serves works fine as usual…but building the apk always sims to get messed up occupationally

i just added JAVA_Home to my environments and the error changed to this:

Execution failed for task ‘:transformClassesWithJarMergingForDebug’. duplicate entry: android/support/v13/view/DragStartHelper$OnDragStartListener.class

so I guessing is best to un-install java and then install a whole new JDK as you suggested before. if I was following correctly???.

ionic works fine as well I checked…

It was definitely an issue about java path, I think.
Glad to hear it works now :slight_smile:

not yet…but im get a feeling we close…“Ionic serve” always worked but “Ionic cordova build android” is the one giving me errors…

@Suluuboi which errors, post there please, i will try to help

also, ionic cordova build can crash for many reasons, do you have a logger of errors?

this is the new error im getting now…

Execution failed for task ‘:transformClassesWithJarMergingForDebug’. duplicate entry: android/support/v13/view/DragStartHelper$OnDragStartListener.class

1 Like

@Suluuboi: i’m not sure but it still looks a JRE issue

I’m thinking :slight_smile:

uninstall and reinstall the JDK and JRE???

Yes, it looks brutal, but ok we can try that
my email is if issue

found a person on line that seemed to mysteriously have come accross the same problem at

it seems this problem started recently maybe one of the plugins are messing up our projects, ill keep on trying your way and also incorporate what other have tried to com up with a solution, the plugins i haave in comon with this person is “phonegap-plugin-push 2.0.0”.