Ionic 2 Templates Unresponsive on iOS


#1

I have an issue where my Ionic 2 app (just the default template with no code changes) does not respond on my lowly iPhone 4S and sometimes does not respond in the iOS simulator either. I’ve tried the default and the tutorial templates, the same happens with both.

Steps to reproduce (assuming ionic is already installed and an iPhone is attached):

ionic start TestApp --v2
cd TestApp
ionic platform add ios
ionic run ios --device (builds successfully but does not deploy first time around so run it again)
ionic run ios --device

Wait for safequit to stop then notice the fade animation to the “Welcome To Ionic!” page.
Tap on the tabs - 9 times out of 10 the app is unresponsive. If it is responsive, quit the app (double tap home key and swipe off) then relaunch it from the home screen.

I’ve tried running the app from inside Xcode and can see that on the occasions when it is unresponsive, the CPU on the device is maxed and the memory utilisation grows rapidly until it crashes.

Has anyone else experienced this? Is there a work-around?

Here’s my ionic info:
Cordova CLI: 6.0.0
Gulp version: CLI version 3.9.1
Gulp local: Local version 3.9.1
Ionic CLI Version: 2.0.0-beta.19
Ionic App Lib Version: 2.0.0-beta.9
ios-deploy version: 1.8.5
ios-sim version: 5.0.6
OS: Mac OS X El Capitan
Node Version: v4.1.0
Xcode version: Xcode 7.2.1 Build version 7C1002

My iPhone 4S is on 9.2.1 (13D15)


#2

Since installing beta 21 (now on beta 22) the situation has improved but there is still a problem. If I start a new project and use the iOS platform components which are now installed by default for a new project, then all is good.

However, if I remove the iOS platform using the ionic CLI, fixup the config.xml to contain a more appropriate widget id (so the bundle identifier ends up correct) then add the iOS platform, the unresponsive problem is reproduced.

Its not a big problem any more because I can use the default iOS components and manually fixup the bundle identifier and other plist items. Just reporting it for a possible fix in the future.


#3

I am facing the same issue. I migrated a small app in Ionic2 and though it runs fine on android, on iOS I get the behaviour you are describing. Care to share your solution in more detail?


#4

The issue was fixed around Ionic CLI Version 21/22, make sure you have the latest beta installed. What’s your “ionic info”?

When creating a new project, always use the iOS platform files which are provided by default from the “ionic start” command. If you remove the iOS platform with “ionic platform remove” and then add it again with “ionic platform add” the issue returns.


#5

Thanks a lot of the information. Saved my day!