Ionic 2.0.0-beta.20 not working on OSX


#1

I am using Ionic 2.0.0-beta.20, npm 3.10.8 and node 6.9.2 LTS. The reason why I want to use this version, is because I have an existing Ionic app of this version built on Windows.

My problem is the following. I have installed Ionic 2.0.0-beta.20 on OSX, but as soon as I try create a new app and serve the app, I get the following errors.

Couldn't find ionic.json file. Are you in an Ionic project?

There is however an ionic.config.json file.

enter image description here

If anyone can please give me some advise how to run Ionic on OSX I would appreciate it. When I do the same on Windows, I don’t seem to have any problems.

Thanks

UPDATE

I downgraded to node 6.2.2, but as you can see, I still get the same error.

enter image description here

UPDATE

As you can see there is an ionic.config.json file. Should I rename it to ionic.json?

enter image description here

UPDATE

package.json

{
  "name": "ionic-app-base",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/common": "2.1.1",
    "@angular/compiler": "2.1.1",
    "@angular/compiler-cli": "2.1.1",
    "@angular/core": "2.1.1",
    "@angular/forms": "2.1.1",
    "@angular/http": "2.1.1",
    "@angular/platform-browser": "2.1.1",
    "@angular/platform-browser-dynamic": "2.1.1",
    "@angular/platform-server": "2.1.1",
    "@ionic/storage": "1.1.6",
    "ionic-angular": "2.0.0-rc.3",
    "ionic-native": "2.2.3",
    "ionicons": "3.0.0",
    "rxjs": "5.0.0-beta.12",
    "zone.js": "0.6.26"
  },
  "devDependencies": {
    "@ionic/app-scripts": "0.0.45",
    "typescript": "2.0.6"
  },
  "cordovaPlugins": [
    "cordova-plugin-whitelist",
    "cordova-plugin-console",
    "cordova-plugin-statusbar",
    "cordova-plugin-device",
    "cordova-plugin-splashscreen",
    "ionic-plugin-keyboard"
  ],
  "cordovaPlatforms": []
}

UPDATE

If I rename the ionic.config.json file to ionic.json, ionic serve starts and tries to open the app in a browser, but gets the following error:

 Error: ENOENT: no such file or directory, open
 '/Users/richardmarais/ionic-apps/theWhoZoo/www/index.html'

#2

Ok, so loosely speaking there’s actually 3 separate operating in an ionic project,

1.) The Ionic CLI
2.) The Ionic App Scripts
3.) The build system (cordova)

It looks like there’s a problem with your Ionic Install on your OS X machine, since your project appears to be throwing errors on the start command.

I’d start by doing this.
sudo npm uninstall ionic cordova
npm install -g ionic cordova
ionic start [projectname] --v2
And see if you have better luck.


#3

Thanks, I tried that but still have the same issues, so I decided to upgrade from the beta to the latest version of Ionic2. However, now I am having problems in the Windows environment too.

Id appreciate it if you could have a look.

I cannot seem to install cordova without errors.