Application Error Ionic2 RC0

Hi everyone. I created a project using command "ionic start --blank --v2. Without edit anything out of the box, I straight away proceed with ‘ionic platform add android’ and ‘ionic run android’. It happens that i got an error.

Error Message

Application Error
net::ERR_FILE NOT_FOUN(file:///android_asset/www/index.html)

Additional information
Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-rc.0
Ionic CLI Version: 2.0.0
Ionic App Lib Version: 2.0.0
OS: Windows 7 SP1
Node Version: v6.5.0


Appreciate if anyone can provide guidance. Should I fall back to beta11 for greater stability?

Can you tell me how to get rc0 ?
is this a newer version than
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1 ?

Hi @axaki7. I just merely type “ionic start [project-name] --blank --v2”. My previous projects were on beta11 with the same command.

yep. I’m having the same issue. Yesterday ‘ionic start’ would still install ionic-angular 2.0.0-beta.11. But since today it installs 2.0.0-rc.0, which is missing dependencies on angular and also putting app folder as a sub-folder of src. In other words, it is all f***ed up :slight_smile:

I am having the same issue on multiple machines( Win10 and OSX, and running both Node LTS and Node 6.7). The www folder is completely empty for projects using the ionic start myApp --v2 command. It appears that some of the .ts and .html files are in the src folder. The js files that are meant to be generated during the build process appear to be missing.

You should update ionic cli.
so you may check this post.



Thanks for the suggestion, but that did not resolve the issue. I found the index file in the .src folder, but it seems some of the .js files (polyfills, cordova) meant to be generated during “start” aren’t produced. I ran start using the verbose tag, but did not notice any errors. I’m not really certain what the target folder structure should be, since I have yet to successfully create an ionic 2 app.

@rdlabo i can confirm that update ionic cli solve the problem entirely. By reinstalling the ionic globally, it solves my problem. Appreciate your help,

I just proceed with npm install -f ionic without removing it.

@k_olivia please try. Thank you.

Edit: “npm install -g ionic” instead of “npm install -f ionic”

1 Like

I had same problem and finally saw that npm was outdates. After installing the update I removed and installed ionic again and everything started working again.
Any one who is having problems with the ionic RC0 install should make sure you have latest version of npm. (current version is 3.10.3)

Thanks again for the response. In case anyone else is still having this problem, on a Win10 machine:

  1. I tried installing ionic without removing it via npm - no effect.
  2. I removed and then reinstalled ionic via npm - no effect - I suspect this is because I had some hidden ionic components in the App/roaming/npm folder
  3. I manually searched and removed all ionic components, and then uninstalled and reinstalled nodejs and npm (0.6.7/3.10.3), then reinstalled ionic. This updated my ionic version from the final beta to CLI 21.1.0. Now I am having the issue reported here [Failed at the ionic-hello-world@ watch script 'ionic-app-scripts watch] when attempting to serve an ionic 2 project.mHowever, this error does not appear if I attempt to serve an old ionic 1 project.