Ionic 1.1.0 and angular 1.4.6


#1

hello there, for iOS9’s related issues, we are using ionic.1.1.0 and angular 1.4.6.
Why latest stable ionic’s version is using Angular based on 1.4.3?
In your opinion, is it safe to run everything with Angular 1.4.6?
Cheers


#2

How do you get that to work?
I have updated my project to use 1.1 and changed bower.json to refer to 1.4.6 instead of 1.4.3.

I have removed the platform and added it again, so everything should be clean, and I can see that the angular.js under the platform is 1.4.6. But when I deploy on a device, and then in Safari debug do angular.version.full it still returns 1.4.3, WTF.

And it looks like it is actually 1.4.3 as I keep getting those dreaded :“Error: [$rootScope:infdig] 10 $digest() iterations reached. Aborting!”

Do you have a clue for me?

Cheers


#3

If you use ionic.bundle.js(1.1.0) you won’t be able to change the angular version. This file itself includes the angular library, in this case 1.4.3


#4

Ahh, I see.

But @canadese90 seams to have a working setup. I guess somehow without ionic.bundle.js.
How is that achieved?


#5

I suppose that he is importing the files included in the ionic bundle one by one. This way you can use the angular version you want.

Anyway, there is a nice post in the Ionic blog that speaks about the iOS9 & Ionic issues. I would try that fixes or wait for a new release.


#6

Yes, I have read that post, but to me it looked like updating to angular.js 1.4.6 was an easier path :smile:

I probably need to revisit that blog, as waiting is not an option for me, unless it is released this weekend :slight_smile:


#7

Basically we are using the ionic bower package (asking the 1.1.0 version) and we included a resolution to force the angular1.4.6

"resolutions": {
    "angular": "~1.4.6"
}

With iOS 9 and XCode 7, it seems to work fine and no “Digest” errors are fired