Import17 is not defined

When I run my ionic app on android it shows white screen after slashscreen, I saw the error on chrome debugging tools saying,

import17 is not defined

Screenshot of the problem:

Please help, thanks.

Edit 1:

My ionic info output:

cli packages: (C:\Users\aksha\Desktop\ionic_apps\askGanesha\node_modules)

    @ionic/cli-utils  : 1.9.2
    ionic (Ionic CLI) : 3.9.2

global packages:

    Cordova CLI : 7.0.1

local packages:

    @ionic/app-scripts : 1.3.7
    Cordova Platforms  : android 6.2.3 browser 4.1.0
    Ionic Framework    : ionic-angular 3.2.1


    Android SDK Tools : 26.0.2
    Node              : v6.10.3
    npm               : 3.10.10
    OS                : Windows 10

Also, the app runs fine when I run on browser using ionic serve.

You should upgrade at least that to a more recent version. (Note the breaking changes in the changelog for 2.x)

How to do it please tell.

Use Google. Ask again if you couldn’t find a solution.

1 Like

Sir I couldn’t find the solution, please help here :cry:

You have to be really bad at googling.

Run npm install @ionic/app-scripts in your project directory. Then do what the app-scripts changelog says for 2.x so your project works again.