How to disable animation?

Hi to all!
Can somebody tell me how can I disable animation when:

  1. popover is dismiss (need to disable delay on fade animation);
  2. when button click (need to disable delay on rip animarion)

I try add option parameter in AppModule import section:
IonicModule.forRoot(MyApp, {
popoverEnter: ‘popover-md-pop-in’,
popoverLeave: ‘’,
activator: ‘’,
actionSheetLeave: ‘’,
modalLeave: ‘’,
pageTransitionDelay: 0
}

animation is gone, but delay is still exist

@rootspain, did you find a solution for this?

@Warri93
No, I still not found any solution for this. But recently I found something intresting around this challenge - in the page about popover https://ionicframework.com/docs/api/components/popover/PopoverController/ placed some information how can disable dismiss animation: The popover will dismiss when the backdrop is clicked by implicitly performing dismiss(null), but this can be disabled by setting enableBackdropDismiss to false in the popover options.
And in this page https://ionicframework.com/docs/theming/platform-specific-styles/ I found some config properties: popoverEnter and popoverLeave
May be its help

Thanks @rootspain!

The way I solved it for my application:
I’ve set the enableBackdropDismiss to false and added a cross in the top corner to close the popover.
When clicking the cross button I call, this.viewCtrl.dismiss(null, null, {animation: false})

I also added animation:false when presenting the popover.

I solve this problem with your’s hint “this.viewCtrl.dismiss(null, null, {animation: false})”.
I’v added to NavOption param “duration” tag.
this.viewCtrl.dismiss(null,null,{‘animation’:‘false’,‘duration’:0});

One more solution with popover in ion-select:

  1. In .html file mark with some identificator, for example <ion-select #mySelector>
  2. In .ts file use @ViewChild(‘mySelector’) pSelector: any;
  3. In .ts file also put line in constructor method or in init method: this.pSelector.config._c.animate = false;

This variant turned off animation directly by code.

This only disable enter animation, leave animation is still displayed.

I prefer to create a custom transition to fix it: